summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/vc4/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2016-08-02 15:01:59 -0700
committerEric Anholt <[email protected]>2016-08-03 10:28:20 -0700
commite97e9e62a1de9689ce8a2a77cb9657b387a1d14b (patch)
treec0843ca5e251e9b284270915ff34119237f2cb3e /src/gallium/drivers/vc4/Makefile.am
parentfd32868590c7cbc5c6c2b3d59ff66694de3864b8 (diff)
vc4: Tell valgrind about BO allocations from mmap time to destroy.
This helps in debugging memory pressure. It would be nice if we could tell valgrind about it all the way from allocation time to destroy, but we need a pointer to hand to VALGRIND_MALLOCLIKE_BLOCK.
Diffstat (limited to 'src/gallium/drivers/vc4/Makefile.am')
-rw-r--r--src/gallium/drivers/vc4/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gallium/drivers/vc4/Makefile.am b/src/gallium/drivers/vc4/Makefile.am
index de82c2c515f..19fc3875955 100644
--- a/src/gallium/drivers/vc4/Makefile.am
+++ b/src/gallium/drivers/vc4/Makefile.am
@@ -32,6 +32,7 @@ AM_CFLAGS = \
$(VC4_CFLAGS) \
$(GALLIUM_DRIVER_CFLAGS) \
$(SIM_CFLAGS) \
+ $(VALGRIND_CFLAGS) \
$()
noinst_LTLIBRARIES = libvc4.la