summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/vc4/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2015-06-03 10:18:04 -0700
committerEric Anholt <[email protected]>2015-06-09 12:25:50 -0700
commit8d10b2a0460ca01a5c65a87184717c6c2e4bcaeb (patch)
tree762465fe1e4aeb55413c8928ee3b1c6d8eef80ec /src/gallium/drivers/vc4/Makefile.am
parente67b12eaf89acc9c446de77b77120a2f6cdbbe12 (diff)
vc4: Drop subdirectory in vc4 build.
Just because we put the source in a subdir, doesn't mean we need helper libraries in the build. This will also simplify the Android build setup.
Diffstat (limited to 'src/gallium/drivers/vc4/Makefile.am')
-rw-r--r--src/gallium/drivers/vc4/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/gallium/drivers/vc4/Makefile.am b/src/gallium/drivers/vc4/Makefile.am
index 3fc591f10c1..774463138d0 100644
--- a/src/gallium/drivers/vc4/Makefile.am
+++ b/src/gallium/drivers/vc4/Makefile.am
@@ -19,8 +19,6 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
-SUBDIRS = kernel
-
include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
@@ -39,5 +37,5 @@ AM_CFLAGS = \
noinst_LTLIBRARIES = libvc4.la
libvc4_la_SOURCES = $(C_SOURCES)
-libvc4_la_LIBADD = $(SIM_LIB) kernel/libvc4_kernel.la
+libvc4_la_LIBADD = $(SIM_LIB)
libvc4_la_LDFLAGS = $(SIM_LDFLAGS)