summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/vc4/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2017-04-13 15:09:16 -0700
committerEric Anholt <[email protected]>2017-05-02 13:35:23 -0700
commita373f77662c557662a675139ea6121b05c1f2b72 (patch)
tree4cb255fbf16e1e81d25201c05ccc5fab9000942e /src/gallium/drivers/vc4/Makefile.am
parent463b7d0332c59d7115642c9922915d097535b4d9 (diff)
vc4: Use a wrapper file to set VC4_BUILD_NEON instead of CFLAGS.
Android.mk was setting the flag across the entire driver, so we didn't have non-NEON versions getting built. This was going to be a problem with the next commit, when I start auto-detecting NEON support and use the non-NEON version when appropriate. Reviewed-by: Rob Herring <[email protected]>
Diffstat (limited to 'src/gallium/drivers/vc4/Makefile.am')
-rw-r--r--src/gallium/drivers/vc4/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/gallium/drivers/vc4/Makefile.am b/src/gallium/drivers/vc4/Makefile.am
index b361a0c588a..0ed49b128b2 100644
--- a/src/gallium/drivers/vc4/Makefile.am
+++ b/src/gallium/drivers/vc4/Makefile.am
@@ -41,10 +41,4 @@ libvc4_la_SOURCES = $(C_SOURCES)
libvc4_la_LIBADD = $(SIM_LIB) $(VC4_LIBS)
libvc4_la_LDFLAGS = $(SIM_LDFLAGS)
-noinst_LTLIBRARIES += libvc4_neon.la
-libvc4_la_LIBADD += libvc4_neon.la
-
-libvc4_neon_la_SOURCES = vc4_tiling_lt.c
-libvc4_neon_la_CFLAGS = $(AM_CFLAGS) -DVC4_BUILD_NEON
-
EXTRA_DIST = kernel/README