summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/vc4/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2014-09-30 16:25:48 -0700
committerEric Anholt <[email protected]>2014-10-09 09:46:39 +0200
commit0b96a086cbb4bcf0a5aab1fee6d77c1e40295297 (patch)
tree469717fdc6feed1f4ab6a3d391782d2d14da6abf /src/gallium/drivers/vc4/Makefile.am
parentef9914aa7481e483d6a12f35ed4eb46b26d17235 (diff)
vc4: Move the mirrored kernel code to a kernel/ directory.
Now this whole setup matches the kernel's file layout much more closely.
Diffstat (limited to 'src/gallium/drivers/vc4/Makefile.am')
-rw-r--r--src/gallium/drivers/vc4/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/gallium/drivers/vc4/Makefile.am b/src/gallium/drivers/vc4/Makefile.am
index 774463138d0..3fc591f10c1 100644
--- a/src/gallium/drivers/vc4/Makefile.am
+++ b/src/gallium/drivers/vc4/Makefile.am
@@ -19,6 +19,8 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
+SUBDIRS = kernel
+
include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
@@ -37,5 +39,5 @@ AM_CFLAGS = \
noinst_LTLIBRARIES = libvc4.la
libvc4_la_SOURCES = $(C_SOURCES)
-libvc4_la_LIBADD = $(SIM_LIB)
+libvc4_la_LIBADD = $(SIM_LIB) kernel/libvc4_kernel.la
libvc4_la_LDFLAGS = $(SIM_LDFLAGS)