summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/v3d/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2019-05-01 15:02:27 -0700
committerEric Anholt <[email protected]>2019-05-13 12:03:11 -0700
commit60a64f028d75ad6ca13468490adf1748cf9f1ec0 (patch)
tree7cdc160a916fc95db2c1154490e9d741df80d210 /src/gallium/drivers/v3d/meson.build
parent0c31fe9ee743f699bcabcb638ccc83e515f0d1bd (diff)
v3d: Use driconf to expose non-MSAA texture limits for Xorg.
The V3D 4.2 HW has a limit to MSAA texture sizes of 4096. With non-MSAA, we can go up to 7680 (actually probably 8138, but that hasn't been validated by the HW team). Exposing 7680 in X11 will allow dual 4k displays.
Diffstat (limited to 'src/gallium/drivers/v3d/meson.build')
-rw-r--r--src/gallium/drivers/v3d/meson.build17
1 files changed, 16 insertions, 1 deletions
diff --git a/src/gallium/drivers/v3d/meson.build b/src/gallium/drivers/v3d/meson.build
index 7f9fdf10ac2..297ff5ce639 100644
--- a/src/gallium/drivers/v3d/meson.build
+++ b/src/gallium/drivers/v3d/meson.build
@@ -50,6 +50,16 @@ files_per_version = files(
'v3dx_state.c',
)
+v3d_driinfo_h = custom_target(
+ 'v3d_driinfo.h',
+ input : files(
+ '../../../util/merge_driinfo.py',
+ '../../auxiliary/pipe-loader/driinfo_gallium.h', 'driinfo_v3d.h'
+ ),
+ output : 'v3d_driinfo.h',
+ command : [prog_python, '@INPUT@'],
+ capture : true,
+)
v3d_args = ['-DV3D_BUILD_NEON']
dep_v3dv3 = dependency('v3dv3', required: false)
@@ -93,7 +103,11 @@ libv3d_neon = static_library(
libv3d = static_library(
'v3d',
- [files_libv3d, v3d_xml_pack],
+ [
+ files_libv3d,
+ v3d_xml_pack,
+ v3d_driinfo_h
+ ],
include_directories : [
inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_broadcom,
inc_gallium_drivers,
@@ -107,5 +121,6 @@ libv3d = static_library(
driver_v3d = declare_dependency(
compile_args : '-DGALLIUM_V3D',
link_with : [libv3d, libv3dwinsys, libbroadcom_cle, libbroadcom_v3d],
+ sources : v3d_driinfo_h,
dependencies : idep_nir,
)