summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/trace/Makefile.am
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2012-08-24 11:46:32 -0700
committerAndreas Boll <[email protected]>2013-01-10 22:01:06 +0100
commit047fe04750acdbc9e807bce955aa890e5d1fd268 (patch)
treee1bac0a3d39be4dda0a8017aed5c61ebdc1b6729 /src/gallium/drivers/trace/Makefile.am
parent34a615018844814d285c9c787ff46539b8adc9aa (diff)
trace: Convert to automake
Diffstat (limited to 'src/gallium/drivers/trace/Makefile.am')
-rw-r--r--src/gallium/drivers/trace/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/gallium/drivers/trace/Makefile.am b/src/gallium/drivers/trace/Makefile.am
new file mode 100644
index 00000000000..9adcef1f53f
--- /dev/null
+++ b/src/gallium/drivers/trace/Makefile.am
@@ -0,0 +1,17 @@
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ $(GALLIUM_CFLAGS)
+
+noinst_LTLIBRARIES = libtrace.la
+
+libtrace_la_SOURCES = \
+ tr_context.c \
+ tr_dump.c \
+ tr_dump_state.c \
+ tr_screen.c \
+ tr_texture.c
+
+#XXX: Delete this when all targets using libtrace are converted to automake
+all-local: libtrace.la
+ ln -f $(builddir)/.libs/libtrace.a $(builddir)/libtrace.a