summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/swr/meson.build
diff options
context:
space:
mode:
authorGeorge Kyriazis <[email protected]>2018-01-31 01:09:53 -0600
committerGeorge Kyriazis <[email protected]>2018-02-16 10:53:59 -0600
commit0420b2be89a4023eb6c1b45740d98184bb77e7cd (patch)
tree75665344e205c1ab391452d76f395863ae6fb37e /src/gallium/drivers/swr/meson.build
parente48dd2489c646745720610bfde6c9f803d9297ed (diff)
swr/rast: Separate event types to public and private
Split into two proto files and modify appropriate build rules for configure / scons / meson builds. There are private internal events (proxy) that communicate information from rasterizer to ArchRast. ArchRast can use these events to calculate a final answer and then emit other public events which will be saved to file. Users will use the public proto file and not the private one. Reviewed-by: Bruce Cherniak <[email protected]>
Diffstat (limited to 'src/gallium/drivers/swr/meson.build')
-rw-r--r--src/gallium/drivers/swr/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gallium/drivers/swr/meson.build b/src/gallium/drivers/swr/meson.build
index a527d5ced19..4bcd4f4e388 100644
--- a/src/gallium/drivers/swr/meson.build
+++ b/src/gallium/drivers/swr/meson.build
@@ -151,6 +151,7 @@ files_swr_arch = files(
swr_context_files = files('swr_context.h')
swr_state_files = files('rasterizer/core/state.h')
swr_event_proto_files = files('rasterizer/archrast/events.proto')
+swr_event_pproto_files = files('rasterizer/archrast/events_private.proto')
swr_gen_backend_files = files('rasterizer/codegen/templates/gen_backend.cpp')
swr_gen_rasterizer_files = files('rasterizer/codegen/templates/gen_rasterizer.cpp')
swr_gen_header_init_files = files('rasterizer/codegen/templates/gen_header_init.hpp')