summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/swr/meson.build
diff options
context:
space:
mode:
authorGeorge Kyriazis <[email protected]>2018-03-13 13:46:41 -0500
committerGeorge Kyriazis <[email protected]>2018-04-18 10:51:38 -0500
commitc2163dc56a237d79e8aea3265e5aba0e603f677d (patch)
tree5309bf79f94b7027b38f35731f9c637243faf57e /src/gallium/drivers/swr/meson.build
parent6427315e435183866f5976bded3aadc97cd6d13a (diff)
swr/rast: Add autogen of helper llvm intrinsics.
Replace sqrt, maskload, fp min/max, cttz, ctlz with llvm equivalent. Replace AVX maskedstore intrinsic with LLVM intrinsic. Add helper llvm macros for stacksave, stackrestore, popcnt. Reviewed-by: Bruce Cherniak <[email protected]>
Diffstat (limited to 'src/gallium/drivers/swr/meson.build')
-rw-r--r--src/gallium/drivers/swr/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gallium/drivers/swr/meson.build b/src/gallium/drivers/swr/meson.build
index e722602403f..91e03abbebc 100644
--- a/src/gallium/drivers/swr/meson.build
+++ b/src/gallium/drivers/swr/meson.build
@@ -300,7 +300,7 @@ endif
libmesaswr = static_library(
'mesaswr',
[files_swr_mesa, files_swr_common, gen_knobs_h, gen_knobs_cpp,
- gen_builder_hpp, gen_builder_x86_hpp],
+ gen_builder_hpp, gen_builder_x86_hpp, gen_builder_intrin_hpp],
cpp_args : [cpp_vis_args, swr_cpp_args, swr_avx_args, swr_arch_defines],
include_directories : [inc_common, swr_incs],
dependencies : dep_llvm,