summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/swr/meson.build
diff options
context:
space:
mode:
authorJan Zielinski <[email protected]>2019-07-17 17:22:16 +0200
committerJan Zielinski <[email protected]>2019-07-18 16:17:00 +0200
commit6f7306c029a7ebe776b513a157b939c866f4d240 (patch)
tree4a32632558b8c5eae6a46bbc2bee0b764b95002b /src/gallium/drivers/swr/meson.build
parent4627a0c4ebc777716e7cadfd80e4f9d5b411762b (diff)
swr/rast: Refactor memory API between rasterizer core and swr
This commit cleans up API between the core of the rasterizer and swr. Some formatting changes are also done. Reviewed-by: Alok Hota <[email protected]>
Diffstat (limited to 'src/gallium/drivers/swr/meson.build')
-rw-r--r--src/gallium/drivers/swr/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/gallium/drivers/swr/meson.build b/src/gallium/drivers/swr/meson.build
index 3f32d031e14..9e07724d5dc 100644
--- a/src/gallium/drivers/swr/meson.build
+++ b/src/gallium/drivers/swr/meson.build
@@ -83,6 +83,7 @@ files_swr_mesa = files(
'rasterizer/jitter/streamout_jit.h',
'rasterizer/jitter/shader_lib/DebugOutput.cpp',
'rasterizer/jitter/functionpasses/lower_x86.cpp',
+ 'rasterizer/memory/SurfaceState.h'
)
files_swr_arch = files(
@@ -153,10 +154,12 @@ files_swr_arch = files(
'rasterizer/memory/tilingtraits.h',
'rasterizer/memory/InitMemory.h',
'rasterizer/memory/InitMemory.cpp',
+ 'rasterizer/memory/SurfaceState.h'
)
swr_context_files = files('swr_context.h')
swr_state_files = files('rasterizer/core/state.h')
+swr_surf_state_files = files('rasterizer/memory/SurfaceState.h')
swr_event_proto_files = files('rasterizer/archrast/events.proto')
swr_event_pproto_files = files('rasterizer/archrast/events_private.proto')
swr_gen_backend_files = files('rasterizer/codegen/templates/gen_backend.cpp')