summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/swr/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-05-27 15:35:43 +0100
committerEmil Velikov <[email protected]>2016-05-30 10:31:07 +0100
commit3a59a624d022e3ba306d42973a1d4ca84ea53dfc (patch)
tree1e220debb338adb85a993173e590415c5ddbcbf3 /src/gallium/drivers/swr/Makefile.am
parentb05b782b4343162bb3c2bb7069d8e2cb413fb6dd (diff)
swr: remove LLVM dependency from source generation rules.
The dependencies should not mention any files external to the project. If we want to do sanity checks for the LLVM installed on the system we should do that in configure, yet again where is the merit which header gets checked and which doesn't ? Cc: Tim Rowley <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/drivers/swr/Makefile.am')
-rw-r--r--src/gallium/drivers/swr/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/gallium/drivers/swr/Makefile.am b/src/gallium/drivers/swr/Makefile.am
index b4317f6f5db..291b5b2167d 100644
--- a/src/gallium/drivers/swr/Makefile.am
+++ b/src/gallium/drivers/swr/Makefile.am
@@ -73,14 +73,14 @@ rasterizer/jitter/state_llvm.h: rasterizer/jitter/scripts/gen_llvm_types.py rast
--input $(srcdir)/rasterizer/core/state.h \
--output rasterizer/jitter/state_llvm.h
-rasterizer/jitter/builder_gen.h: rasterizer/jitter/scripts/gen_llvm_ir_macros.py $(LLVM_INCLUDEDIR)/llvm/IR/IRBuilder.h
+rasterizer/jitter/builder_gen.h: rasterizer/jitter/scripts/gen_llvm_ir_macros.py
$(PYTHON2) $(PYTHON_FLAGS) \
$(srcdir)/rasterizer/jitter/scripts/gen_llvm_ir_macros.py \
--input $(LLVM_INCLUDEDIR)/llvm/IR/IRBuilder.h \
--output rasterizer/jitter/builder_gen.h \
--gen_h
-rasterizer/jitter/builder_gen.cpp: rasterizer/jitter/scripts/gen_llvm_ir_macros.py $(LLVM_INCLUDEDIR)/llvm/IR/IRBuilder.h
+rasterizer/jitter/builder_gen.cpp: rasterizer/jitter/scripts/gen_llvm_ir_macros.py
$(PYTHON2) $(PYTHON_FLAGS) \
$(srcdir)/rasterizer/jitter/scripts/gen_llvm_ir_macros.py \
--input $(LLVM_INCLUDEDIR)/llvm/IR/IRBuilder.h \