summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/swr/Makefile.am
diff options
context:
space:
mode:
authorAlok Hota <[email protected]>2019-02-19 14:29:35 -0600
committerAlok Hota <[email protected]>2019-02-25 13:05:39 -0600
commit773b3ceacaf6d32135348e07878b8514a4350b0e (patch)
tree9b50099f434adfec901bd0a23e1eeac70573b0bb /src/gallium/drivers/swr/Makefile.am
parent16e10b8c304481e423e76311f70de5de9e7424b1 (diff)
swr/rast: Fix autotools and scons codegen
Use new input flags for gen_archrast.py Reviewed-by: Bruce Cherniak <[email protected]>
Diffstat (limited to 'src/gallium/drivers/swr/Makefile.am')
-rw-r--r--src/gallium/drivers/swr/Makefile.am24
1 files changed, 8 insertions, 16 deletions
diff --git a/src/gallium/drivers/swr/Makefile.am b/src/gallium/drivers/swr/Makefile.am
index 3390ef6b096..81bfaca54fa 100644
--- a/src/gallium/drivers/swr/Makefile.am
+++ b/src/gallium/drivers/swr/Makefile.am
@@ -159,40 +159,32 @@ rasterizer/archrast/gen_ar_event.hpp: rasterizer/codegen/gen_archrast.py rasteri
$(MKDIR_GEN)
$(PYTHON_GEN) \
$(srcdir)/rasterizer/codegen/gen_archrast.py \
- --proto $(srcdir)/rasterizer/archrast/events.proto \
- --proto_private $(srcdir)/rasterizer/archrast/events_private.proto \
- --output rasterizer/archrast/gen_ar_event.hpp \
- --gen_event_hpp
+ --proto $(srcdir)/rasterizer/archrast/events.proto $(srcdir)/rasterizer/archrast/events_private.proto \
+ --output-dir rasterizer/codegen
$(AM_V_GEN)touch $@
rasterizer/archrast/gen_ar_event.cpp: rasterizer/codegen/gen_archrast.py rasterizer/codegen/templates/gen_ar_event.cpp rasterizer/archrast/events.proto rasterizer/archrast/events_private.proto rasterizer/codegen/gen_common.py
$(MKDIR_GEN)
$(PYTHON_GEN) \
$(srcdir)/rasterizer/codegen/gen_archrast.py \
- --proto $(srcdir)/rasterizer/archrast/events.proto \
- --proto_private $(srcdir)/rasterizer/archrast/events_private.proto \
- --output rasterizer/archrast/gen_ar_event.cpp \
- --gen_event_cpp
+ --proto $(srcdir)/rasterizer/archrast/events.proto $(srcdir)/rasterizer/archrast/events_private.proto \
+ --output-dir rasterizer/codegen
$(AM_V_GEN)touch $@
rasterizer/archrast/gen_ar_eventhandler.hpp: rasterizer/codegen/gen_archrast.py rasterizer/codegen/templates/gen_ar_eventhandler.hpp rasterizer/archrast/events.proto rasterizer/archrast/events_private.proto rasterizer/codegen/gen_common.py
$(MKDIR_GEN)
$(PYTHON_GEN) \
$(srcdir)/rasterizer/codegen/gen_archrast.py \
- --proto $(srcdir)/rasterizer/archrast/events.proto \
- --proto_private $(srcdir)/rasterizer/archrast/events_private.proto \
- --output rasterizer/archrast/gen_ar_eventhandler.hpp \
- --gen_eventhandler_hpp
+ --proto $(srcdir)/rasterizer/archrast/events.proto $(srcdir)/rasterizer/archrast/events_private.proto \
+ --output-dir rasterizer/codegen
$(AM_V_GEN)touch $@
rasterizer/archrast/gen_ar_eventhandlerfile.hpp: rasterizer/codegen/gen_archrast.py rasterizer/codegen/templates/gen_ar_eventhandlerfile.hpp rasterizer/archrast/events.proto rasterizer/archrast/events_private.proto rasterizer/codegen/gen_common.py
$(MKDIR_GEN)
$(PYTHON_GEN) \
$(srcdir)/rasterizer/codegen/gen_archrast.py \
- --proto $(srcdir)/rasterizer/archrast/events.proto \
- --proto_private $(srcdir)/rasterizer/archrast/events_private.proto \
- --output rasterizer/archrast/gen_ar_eventhandlerfile.hpp \
- --gen_eventhandlerfile_hpp
+ --proto $(srcdir)/rasterizer/archrast/events.proto $(srcdir)/rasterizer/archrast/events_private.proto \
+ --output-dir rasterizer/codegen
$(AM_V_GEN)touch $@
rasterizer/core/backends/gen_BackendPixelRate0.cpp \