summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/softpipe/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2013-05-08 23:28:04 +0100
committerTom Stellard <[email protected]>2013-10-01 07:29:49 -0700
commit9bc5ced1c7940820ce59d5e4bd2ca6a48b643e1d (patch)
tree3751f36d04c84493762199bd7b58a100b62237d3 /src/gallium/drivers/softpipe/Makefile.am
parent6ea73bb39528401fe5aca7c52692f7f6a628c6a7 (diff)
softpipe: consolidate C sources list into Makefile.sources
Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/drivers/softpipe/Makefile.am')
-rw-r--r--src/gallium/drivers/softpipe/Makefile.am32
1 files changed, 2 insertions, 30 deletions
diff --git a/src/gallium/drivers/softpipe/Makefile.am b/src/gallium/drivers/softpipe/Makefile.am
index 52ce958e20f..432fe7d6fc2 100644
--- a/src/gallium/drivers/softpipe/Makefile.am
+++ b/src/gallium/drivers/softpipe/Makefile.am
@@ -20,6 +20,7 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
# DEALINGS IN THE SOFTWARE.
+include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
AM_CPPFLAGS = \
@@ -29,33 +30,4 @@ AM_CPPFLAGS = \
noinst_LTLIBRARIES = libsoftpipe.la
-libsoftpipe_la_SOURCES = \
- sp_fs_exec.c \
- sp_clear.c \
- sp_fence.c \
- sp_flush.c \
- sp_query.c \
- sp_context.c \
- sp_draw_arrays.c \
- sp_prim_vbuf.c \
- sp_quad_pipe.c \
- sp_quad_stipple.c \
- sp_quad_depth_test.c \
- sp_quad_fs.c \
- sp_quad_blend.c \
- sp_screen.c \
- sp_setup.c \
- sp_state_blend.c \
- sp_state_clip.c \
- sp_state_derived.c \
- sp_state_sampler.c \
- sp_state_shader.c \
- sp_state_so.c \
- sp_state_rasterizer.c \
- sp_state_surface.c \
- sp_state_vertex.c \
- sp_texture.c \
- sp_tex_sample.c \
- sp_tex_tile_cache.c \
- sp_tile_cache.c \
- sp_surface.c
+libsoftpipe_la_SOURCES = $(C_SOURCES)