aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/rbug/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-09-29 20:21:23 -0700
committerDylan Baker <[email protected]>2017-10-16 16:32:43 -0700
commit4d701ee9696ff7fdbce5c56cc3a97a326f06f16f (patch)
tree9b0881810a2b42e0aa54dde24b91b99bef5b90dc /src/gallium/drivers/rbug/meson.build
parentd451a11b214a7191a6997edef009dd4a50e8e841 (diff)
meson: build gallium helper drivers
This builds ddebug, noop, rbug, and trace drivers. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <eric at anholt.net>
Diffstat (limited to 'src/gallium/drivers/rbug/meson.build')
-rw-r--r--src/gallium/drivers/rbug/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/gallium/drivers/rbug/meson.build b/src/gallium/drivers/rbug/meson.build
new file mode 100644
index 00000000000..9c74171f7b5
--- /dev/null
+++ b/src/gallium/drivers/rbug/meson.build
@@ -0,0 +1,28 @@
+# Copyright © 2017 Dylan Baker
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+librbug = static_library(
+ 'rbug',
+ files('rbug_context.c', 'rbug_context.h', 'rbug_core.c', 'rbug_objects.c',
+ 'rbug_objects.h', 'rbug_public.h', 'rbug_screen.c', 'rbug_screen.h'),
+ include_directories : [inc_gallium, inc_gallium_aux, inc_include, inc_src],
+ c_args : [c_vis_args],
+ build_by_default : false,
+)