summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/radeonsi/Makefile.am
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2018-04-01 20:34:40 -0400
committerMarek Olšák <[email protected]>2018-04-05 15:34:58 -0400
commit38faac43e32d58ce7b42d35e11146208f2c7b4e5 (patch)
tree3206529216fc7823fac48f87fd90f1d856422c86 /src/gallium/drivers/radeonsi/Makefile.am
parentf9323ddbb9de667475d12f7a9183a855f3f33ac8 (diff)
radeonsi: don't build libradeon.la separately
for better parallelism Acked-by: Timothy Arceri <[email protected]>
Diffstat (limited to 'src/gallium/drivers/radeonsi/Makefile.am')
-rw-r--r--src/gallium/drivers/radeonsi/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/gallium/drivers/radeonsi/Makefile.am b/src/gallium/drivers/radeonsi/Makefile.am
index b39c55944cd..62b877d4ea4 100644
--- a/src/gallium/drivers/radeonsi/Makefile.am
+++ b/src/gallium/drivers/radeonsi/Makefile.am
@@ -37,6 +37,13 @@ noinst_LTLIBRARIES = libradeonsi.la
libradeonsi_la_SOURCES = $(C_SOURCES)
+libradeonsi_la_LIBADD = \
+ $(CLOCK_LIB) \
+ $(LLVM_LIBS)
+
+libradeonsi_la_LDFLAGS = \
+ $(LLVM_LDFLAGS)
+
GEN_DRIINFO_INPUTS = \
$(top_srcdir)/src/gallium/auxiliary/pipe-loader/driinfo_gallium.h \
$(srcdir)/driinfo_radeonsi.h