summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/radeon/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-05-10 14:25:08 +0100
committerEmil Velikov <[email protected]>2014-05-15 17:32:30 +0100
commit6fcc0b0ba5b5a554682b782ee5f7930d7aabbe8e (patch)
tree1d76a41a1232fd330b286e60996d098d5d9d5879 /src/gallium/drivers/radeon/Makefile.am
parent670418740fc763f0272b799ea999cd3ff69b1218 (diff)
gallium/radeon: build only a single common library libradeon
Just fold libllvmradeon in libradeon. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/drivers/radeon/Makefile.am')
-rw-r--r--src/gallium/drivers/radeon/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/src/gallium/drivers/radeon/Makefile.am b/src/gallium/drivers/radeon/Makefile.am
index b521658b02c..e2c980f614e 100644
--- a/src/gallium/drivers/radeon/Makefile.am
+++ b/src/gallium/drivers/radeon/Makefile.am
@@ -13,22 +13,18 @@ libradeon_la_SOURCES = \
if NEED_RADEON_LLVM
-noinst_LTLIBRARIES += libllvmradeon.la
-
-libllvmradeon_la_CFLAGS = \
- $(GALLIUM_DRIVER_CFLAGS) \
- $(RADEON_CFLAGS) \
+AM_CFLAGS += \
$(LLVM_CFLAGS)
-libllvmradeon_la_SOURCES = \
+libradeon_la_SOURCES += \
$(LLVM_C_FILES)
-libllvmradeon_la_LIBADD = \
+libradeon_la_LIBADD = \
$(CLOCK_LIB) \
$(LLVM_LIBS) \
$(ELF_LIB)
-libllvmradeon_la_LDFLAGS = \
+libradeon_la_LDFLAGS = \
$(LLVM_LDFLAGS)
endif