summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/r600/Makefile.am
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2013-04-23 20:14:01 -0700
committerTom Stellard <[email protected]>2013-05-06 09:06:10 -0700
commit914d797797b5b835eeaffb56f04a2ca3f2e120b6 (patch)
tree885ac27fc2a46364bf27abf04a093dc4a80dc396 /src/gallium/drivers/r600/Makefile.am
parent024fe6852a76f33d7e2afc5621340e387c381bb0 (diff)
radeon/llvm: Always build libradeonllvm as static
This library is very small, so there is not much to gain from building it as a shared library. Also, when linking statically with LLVM, a shared libradeonllvm exports LLVM symbols and creates problems when used with other shared objects that also link statically to LLVM. Reviewed-by: [email protected]
Diffstat (limited to 'src/gallium/drivers/r600/Makefile.am')
-rw-r--r--src/gallium/drivers/r600/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gallium/drivers/r600/Makefile.am b/src/gallium/drivers/r600/Makefile.am
index 08d7e2ce341..9203d03292b 100644
--- a/src/gallium/drivers/r600/Makefile.am
+++ b/src/gallium/drivers/r600/Makefile.am
@@ -29,7 +29,7 @@ if R600_NEED_RADEON_GALLIUM
libr600_la_SOURCES += \
$(LLVM_C_SOURCES)
-libr600_la_LIBADD += ../radeon/libllvmradeon@[email protected]
+libr600_la_LIBADD += ../radeon/libllvmradeon.la
AM_CFLAGS += \
$(LLVM_CFLAGS) \