summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/r600/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-05-10 14:35:08 +0100
committerEmil Velikov <[email protected]>2014-05-15 17:32:30 +0100
commitd812c745829be2155fdd0d10e4a12606c2a10826 (patch)
tree21177e54bb2eb6676774ca478b153b80276f6014 /src/gallium/drivers/r600/Makefile.am
parent6fcc0b0ba5b5a554682b782ee5f7930d7aabbe8e (diff)
gallium/radeon: link in libradeon.la at target level
It makes more sense to link the core and common parts of the driver as the target is build. Additionally this will help us drop duplicating symbols for targets that static link mulitple pipe-drivers. Only egl-static needs that currently with more to come. To simplify things a bit add HAVE_GALLIUM_RADEON_COMMON variable. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/drivers/r600/Makefile.am')
-rw-r--r--src/gallium/drivers/r600/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/gallium/drivers/r600/Makefile.am b/src/gallium/drivers/r600/Makefile.am
index be8635d26e2..30e098e1770 100644
--- a/src/gallium/drivers/r600/Makefile.am
+++ b/src/gallium/drivers/r600/Makefile.am
@@ -17,8 +17,6 @@ libr600_la_SOURCES = \
$(C_SOURCES) \
$(CXX_SOURCES)
-libr600_la_LIBADD = ../radeon/libradeon.la
-
if NEED_RADEON_LLVM
AM_CFLAGS += \