summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/r300/Makefile.am
diff options
context:
space:
mode:
authorKenneth Graunke <[email protected]>2014-02-24 23:39:14 -0800
committerJason Ekstrand <[email protected]>2014-08-04 11:06:58 -0700
commit1e0da6233be6e5fb0143615d5e3d3642ddb7964f (patch)
treeb33478332a051d4d587009cc8a76b71c5210bdc6 /src/gallium/drivers/r300/Makefile.am
parentdcc29c18b4affd0a69202a822ffe77d94594f98b (diff)
util: Move ralloc to a new src/util directory.
For a long time, we've wanted a place to put utility code which isn't directly tied to Mesa or Gallium internals. This patch creates a new src/util directory for exactly that purpose, and builds the contents as libmesautil.la. ralloc seemed like a good first candidate. These days, it's directly used by mesa/main, i965, i915, and r300g, so keeping it in src/glsl didn't make much sense. Signed-off-by: Kenneth Graunke <[email protected]> v2 (Jason Ekstrand): More realloc uses and some scons fixes Signed-off-by: Jason Ekstrand <[email protected]> Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/gallium/drivers/r300/Makefile.am')
-rw-r--r--src/gallium/drivers/r300/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/gallium/drivers/r300/Makefile.am b/src/gallium/drivers/r300/Makefile.am
index a8aaf221c9a..2c5951b8f6d 100644
--- a/src/gallium/drivers/r300/Makefile.am
+++ b/src/gallium/drivers/r300/Makefile.am
@@ -4,6 +4,7 @@ include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
AM_CFLAGS = \
+ -I$(top_srcdir)/src/util \
-I$(top_srcdir)/src/mesa/program \
-I$(top_srcdir)/src/mesa \
-I$(top_srcdir)/src/glsl \
@@ -17,6 +18,7 @@ check_PROGRAMS = r300_compiler_tests
TESTS = r300_compiler_tests
r300_compiler_tests_LDADD = libr300.la libr300-helper.la \
+ $(top_builddir)/src/util/libmesautil.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(GALLIUM_COMMON_LIB_DEPS)
r300_compiler_tests_CPPFLAGS = \
@@ -32,4 +34,5 @@ libr300_la_SOURCES = $(C_SOURCES)
#
# Solve this by building them into a separate helper library that can be linked
# in place of libmesagallium.
+libr300_helper_la_CPPFLAGS = -I$(top_srcdir)/src
libr300_helper_la_SOURCES = $(HELPER_SOURCES)