summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/r300/Makefile.am
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2013-02-10 00:15:12 -0500
committerTom Stellard <[email protected]>2013-02-21 22:07:28 -0500
commit10bcc843f8898c2466b610d08edc27516e10cc51 (patch)
tree921ed89301af2f0fae762652f43c46765fc322d0 /src/gallium/drivers/r300/Makefile.am
parent5e1321ddf4dacb212ed3215f2b9beead630353a1 (diff)
r300g/compiler: Fix bug in OMOD folding
The OMOD value was only being folded to one instruction in cases where the MUL instruction was reading a value written by more than one instruction. NOTE: This is a candidate for the stable branches. Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'src/gallium/drivers/r300/Makefile.am')
-rw-r--r--src/gallium/drivers/r300/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gallium/drivers/r300/Makefile.am b/src/gallium/drivers/r300/Makefile.am
index 2da9bf9f41d..49264c4a719 100644
--- a/src/gallium/drivers/r300/Makefile.am
+++ b/src/gallium/drivers/r300/Makefile.am
@@ -22,6 +22,7 @@ r300_compiler_tests_CPPFLAGS = \
-I$(top_srcdir)/src/gallium/drivers/r300/compiler
r300_compiler_tests_SOURCES = \
$(testdir)/r300_compiler_tests.c \
+ $(testdir)/radeon_compiler_optimize_tests.c \
$(testdir)/radeon_compiler_util_tests.c \
$(testdir)/rc_test_helpers.c \
$(testdir)/unit_test.c