summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/panfrost/meson.build
diff options
context:
space:
mode:
authorAlyssa Rosenzweig <[email protected]>2019-07-10 10:33:24 -0700
committerAlyssa Rosenzweig <[email protected]>2019-07-10 10:43:23 -0700
commitec2a59cd7aa42652645e76e29a72335370c80e50 (patch)
tree08e75a12d073cc627307bc59ab3a8d057244b68e /src/gallium/drivers/panfrost/meson.build
parenta2d0ea92ba752c62e59aa681acda7b97fc86d100 (diff)
panfrost: Move non-Gallium files outside of Gallium
In preparation for a Panfrost-based non-Gallium driver (maybe Vulkan...?), hoist everything except for the Gallium driver into a shared src/panfrost. Practically, that means the compilers, the headers, and pandecode. Signed-off-by: Alyssa Rosenzweig <[email protected]>
Diffstat (limited to 'src/gallium/drivers/panfrost/meson.build')
-rw-r--r--src/gallium/drivers/panfrost/meson.build90
1 files changed, 2 insertions, 88 deletions
diff --git a/src/gallium/drivers/panfrost/meson.build b/src/gallium/drivers/panfrost/meson.build
index f3067c6a784..7fdbddc0268 100644
--- a/src/gallium/drivers/panfrost/meson.build
+++ b/src/gallium/drivers/panfrost/meson.build
@@ -26,27 +26,10 @@ files_panfrost = files(
'pan_resource.c',
'pan_resource.h',
- 'midgard/midgard_compile.c',
- 'midgard/mir.c',
- 'midgard/midgard_print.c',
- 'midgard/midgard_schedule.c',
- 'midgard/midgard_emit.c',
- 'midgard/midgard_ra.c',
- 'midgard/midgard_ra_pipeline.c',
- 'midgard/midgard_liveness.c',
- 'midgard/midgard_ops.c',
- 'midgard/cppwrap.cpp',
- 'midgard/disassemble.c',
-
'nir/nir_undef_to_zero.c',
'nir/nir_lower_blend.c',
'nir/nir_lower_framebuffer.c',
- 'bifrost/disassemble.c',
-
- 'pandecode/common.c',
- 'pandecode/decode.c',
-
'pan_context.c',
'pan_afbc.c',
'pan_blit.c',
@@ -58,7 +41,6 @@ files_panfrost = files(
'pan_blending.c',
'pan_blend_shaders.c',
'pan_blend_cso.c',
- 'pan_pretty_print.c',
'pan_fragment.c',
'pan_invocation.c',
'pan_instancing.c',
@@ -75,9 +57,6 @@ panfrost_includes = [
inc_include,
inc_src,
inc_panfrost,
- include_directories('include'),
- include_directories('midgard'),
- include_directories('bifrost'),
]
compile_args_panfrost = [
@@ -85,21 +64,9 @@ compile_args_panfrost = [
'-Wno-pointer-arith'
]
-midgard_nir_algebraic_c = custom_target(
- 'midgard_nir_algebraic.c',
- input : 'midgard/midgard_nir_algebraic.py',
- output : 'midgard_nir_algebraic.c',
- command : [
- prog_python, '@INPUT@',
- '-p', join_paths(meson.source_root(), 'src/compiler/nir/'),
- ],
- capture : true,
- depend_files : nir_algebraic_py,
-)
-
libpanfrost = static_library(
'panfrost',
- [files_panfrost, midgard_nir_algebraic_c],
+ files_panfrost,
dependencies: [
dep_thread,
dep_libdrm,
@@ -111,58 +78,5 @@ libpanfrost = static_library(
driver_panfrost = declare_dependency(
compile_args : compile_args_panfrost,
- link_with : [libpanfrost, libpanfrostwinsys, libpanfrost_shared],
-)
-
-files_bifrost = files(
- 'bifrost/disassemble.c',
- 'bifrost/cmdline.c',
-)
-
-bifrost_compiler = executable(
- 'bifrost_compiler',
- [files_bifrost],
- include_directories : [
- inc_common,
- inc_src,
- inc_include,
- inc_gallium,
- inc_gallium_aux,
- include_directories('bifrost')
- ],
- dependencies : [
- dep_thread,
- idep_nir
- ],
- link_with : [
- libgallium,
- libglsl_standalone,
- libmesa_util
- ],
- build_by_default : true
-)
-
-files_pandecode = files(
- 'pandecode/cmdline.c',
- 'pandecode/common.c',
- 'pandecode/decode.c',
-
- 'pan_pretty_print.c',
-
- 'midgard/disassemble.c',
- 'midgard/midgard_ops.c',
- 'bifrost/disassemble.c',
-)
-
-pandecode = executable(
- 'pandecode',
- files_pandecode,
- include_directories : panfrost_includes,
- dependencies : [
- dep_thread,
- ],
- link_with : [
- libmesa_util
- ],
- build_by_default : true
+ link_with : [libpanfrost, libpanfrostwinsys, libpanfrost_shared, libpanfrost_midgard, libpanfrost_bifrost, libpanfrost_decode],
)