summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/panfrost/meson.build
diff options
context:
space:
mode:
authorAlyssa Rosenzweig <[email protected]>2019-06-27 14:13:10 -0700
committerAlyssa Rosenzweig <[email protected]>2019-07-01 07:50:57 -0700
commit8d74749f812e64968d37266061293e204fea252c (patch)
treedf6d072cef24746172e57214b5a06d1cb4689749 /src/gallium/drivers/panfrost/meson.build
parente9e22546ffd76c6d0738f12d702c54e7758d9e1f (diff)
panfrost: Implement instanced rendering
We implement GLES3.0 instanced rendering with full support for instanced arrays (via instance divisors). To do so, we use the new invocation helpers to invoke a triplet of (1, vertex_count, instance_count), rather than simply (1, vertex_count, 1). We rewrite the attribute handling code into a new pan_instancing.c file which handles both the simple LINEAR case for non-instanced as well as each of the new instancing cases: MODULO (for per-vertex attributes), POT and NPOT divisors. As a side effect, we rework how vertex buffers are handled, duplicating them to be 1:1 with vertex descriptors to simplify instancing code paths dramatically. This might be a performance regression, but this remains to be seen; if so, we can always deduplicate later with some added logic in pan_instancing.c Signed-off-by: Alyssa Rosenzweig <[email protected]>
Diffstat (limited to 'src/gallium/drivers/panfrost/meson.build')
-rw-r--r--src/gallium/drivers/panfrost/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gallium/drivers/panfrost/meson.build b/src/gallium/drivers/panfrost/meson.build
index 80cfee794db..b69b41bfd90 100644
--- a/src/gallium/drivers/panfrost/meson.build
+++ b/src/gallium/drivers/panfrost/meson.build
@@ -58,6 +58,7 @@ files_panfrost = files(
'pan_pretty_print.c',
'pan_fragment.c',
'pan_invocation.c',
+ 'pan_instancing.c',
'pan_scoreboard.c',
'pan_sfbd.c',
'pan_mfbd.c',