summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/nouveau/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2013-11-01 18:58:27 +0000
committerEmil Velikov <[email protected]>2013-11-16 16:29:28 +0000
commit7dac1b470a9c1c977f79ecc301407681e200bd1a (patch)
tree39c8b75ac8223811cf006c87658c1b131e75cb0f /src/gallium/drivers/nouveau/Makefile.am
parentad501a535ad731447587b259afe2ea9c0a0a02f5 (diff)
gallium/drivers: compact compiler flags into Automake.inc
* minimise flags duplication * distingush between VISIBILITY C and CXX flags * set only required flags - C and/or CXX v2: add LLVM_CFLAGS back to AM_CFLAGS (add missing backslash) Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/drivers/nouveau/Makefile.am')
-rw-r--r--src/gallium/drivers/nouveau/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/gallium/drivers/nouveau/Makefile.am b/src/gallium/drivers/nouveau/Makefile.am
index 369dadabdd2..7c052231bfa 100644
--- a/src/gallium/drivers/nouveau/Makefile.am
+++ b/src/gallium/drivers/nouveau/Makefile.am
@@ -25,14 +25,12 @@ AUTOMAKE_OPTIONS = subdir-objects
include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
-noinst_LTLIBRARIES = libnouveau.la
-
AM_CPPFLAGS = \
- -I$(top_srcdir)/src/gallium/drivers/nouveau/include \
- $(GALLIUM_CFLAGS) \
+ $(GALLIUM_DRIVER_CFLAGS) \
$(LIBDRM_CFLAGS) \
- $(NOUVEAU_CFLAGS) \
- $(VISIBILITY_CFLAGS)
+ $(NOUVEAU_CFLAGS)
+
+noinst_LTLIBRARIES = libnouveau.la
libnouveau_la_SOURCES = \
$(C_SOURCES) \