summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/nouveau/Makefile.am
diff options
context:
space:
mode:
authorIlia Mirkin <[email protected]>2014-02-21 01:05:10 -0500
committerIlia Mirkin <[email protected]>2014-02-26 23:35:48 -0500
commit51fc093421e4ed672ae3cba5a7f3695f3972e658 (patch)
tree408b93a230b13f822007fbe1e39d44f247073697 /src/gallium/drivers/nouveau/Makefile.am
parentdd370f0af69470b1e833298a1a7ea0d0254a31a3 (diff)
nouveau: add a nouveau_compiler binary to compile TGSI into shader ISA
This makes it easy to compare output between different cards, especially for ones that you don't have (and/or not in the current machine). Signed-off-by: Ilia Mirkin <[email protected]>
Diffstat (limited to 'src/gallium/drivers/nouveau/Makefile.am')
-rw-r--r--src/gallium/drivers/nouveau/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/gallium/drivers/nouveau/Makefile.am b/src/gallium/drivers/nouveau/Makefile.am
index 7c052231bfa..ac4f9bbcbf3 100644
--- a/src/gallium/drivers/nouveau/Makefile.am
+++ b/src/gallium/drivers/nouveau/Makefile.am
@@ -39,3 +39,15 @@ libnouveau_la_SOURCES = \
$(NV50_C_SOURCES) \
$(NVC0_CODEGEN_SOURCES) \
$(NVC0_C_SOURCES)
+
+noinst_PROGRAMS = nouveau_compiler
+
+nouveau_compiler_SOURCES = \
+ nouveau_compiler.c
+
+nouveau_compiler_LDADD = \
+ libnouveau.la \
+ ../../auxiliary/libgallium.la \
+ -lstdc++ \
+ -lm \
+ -ldl