summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/noop/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2013-06-05 23:33:38 +0100
committerTom Stellard <[email protected]>2013-10-01 07:29:50 -0700
commit38d80c01d0a00148989f84631707ade9dc52e8e3 (patch)
tree02770828e778077dd64b054d11915a663b60484a /src/gallium/drivers/noop/Makefile.am
parentd7c66ff59ef07abe85a2867f82326376f94386e3 (diff)
noop: consolidate C sources list into Makefile.sources
Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/drivers/noop/Makefile.am')
-rw-r--r--src/gallium/drivers/noop/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/gallium/drivers/noop/Makefile.am b/src/gallium/drivers/noop/Makefile.am
new file mode 100644
index 00000000000..1f4ba028f7f
--- /dev/null
+++ b/src/gallium/drivers/noop/Makefile.am
@@ -0,0 +1,16 @@
+################################################################################
+
+# Meta-driver which combines whichever software rasterizers have been
+# built into a single convenience library.
+
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/src/gallium/drivers \
+ $(GALLIUM_CFLAGS) \
+ $(VISIBILITY_CFLAGS)
+
+noinst_LTLIBRARIES = libnoop.la
+
+libnoop_la_SOURCES = $(C_SOURCES)