summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/llvmpipe/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-10 09:17:08 -0800
committerDylan Baker <[email protected]>2017-11-13 13:43:12 -0800
commit2bfd34c518134dd656f4f23f3c6c8acb1eeda507 (patch)
treed7146ef7faafc54e40ca82792d35b46e1c55453f /src/gallium/drivers/llvmpipe/meson.build
parent63b6eb9cb92238e7aff71de680c18f5d1d1bcd91 (diff)
meson: don't use build_by_default for specific gallium drivers
Using build_by_default : false is convenient for dependencies that can be pulled in by various diverse components of the build system, the gallium hardware/software drivers and state trackers do not fit that description. Instead, these should be guarded using the variable that tracks whether that driver should be enabled. This leaves a few helper libraries: trace, rbug, etc, and the generic winsys bits as `build_by_default : false` because there are a large number of gallium components that pull them in. v2: - remove build_by_default from winsys convenience libs as well. v3: - Always put drivers before winsys for consistency Signed-off-by: Dylan Baker <[email protected]> Tested-by: Lionel Landwerlin <[email protected]> (v1) Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/gallium/drivers/llvmpipe/meson.build')
-rw-r--r--src/gallium/drivers/llvmpipe/meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/gallium/drivers/llvmpipe/meson.build b/src/gallium/drivers/llvmpipe/meson.build
index ca1d2aa797b..9d0edb0ac33 100644
--- a/src/gallium/drivers/llvmpipe/meson.build
+++ b/src/gallium/drivers/llvmpipe/meson.build
@@ -98,7 +98,6 @@ libllvmpipe = static_library(
cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
include_directories : [inc_gallium, inc_gallium_aux, inc_include, inc_src],
dependencies : dep_llvm,
- build_by_default : false,
)
if with_tests and with_gallium_softpipe and with_llvm