aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/llvmpipe/meson.build
diff options
context:
space:
mode:
authorDave Airlie <[email protected]>2019-08-27 12:45:39 +1000
committerDave Airlie <[email protected]>2019-09-04 15:22:20 +1000
commit1b24e3ba756ba4951086d0b1b351364acbd3af1d (patch)
treecfc91c2dbdc99f9dce4040ad9980a1ab5105420b /src/gallium/drivers/llvmpipe/meson.build
parente5bf6b70135fc39483247fbb385d514f3516c4af (diff)
llvmpipe: add compute threadpool + mutex
Reviewed-by: Roland Scheidegger <[email protected]> In order to efficiently run a number of compute blocks, use a threadpool that just allows for jobs with unique sequential ids to be dispatched.
Diffstat (limited to 'src/gallium/drivers/llvmpipe/meson.build')
-rw-r--r--src/gallium/drivers/llvmpipe/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/gallium/drivers/llvmpipe/meson.build b/src/gallium/drivers/llvmpipe/meson.build
index 6ad3017bf8d..7eb752c8e97 100644
--- a/src/gallium/drivers/llvmpipe/meson.build
+++ b/src/gallium/drivers/llvmpipe/meson.build
@@ -33,6 +33,8 @@ files_llvmpipe = files(
'lp_clear.h',
'lp_context.c',
'lp_context.h',
+ 'lp_cs_tpool.h',
+ 'lp_cs_tpool.c',
'lp_debug.h',
'lp_draw_arrays.c',
'lp_fence.c',