summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/llvmpipe/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-08-29 22:49:19 +0100
committerEmil Velikov <[email protected]>2014-09-05 23:46:25 +0100
commit48d251cebbcd5246f65c8d0913bd7a5e56cc30c6 (patch)
tree290b6771438e032d5680d468af0d31e462ab0af5 /src/gallium/drivers/llvmpipe/Makefile.am
parenta408b7584978993fe0860af964c7e337cdbcf8db (diff)
gallium/llvmpipe: ship all files in the tarball
- include all headers in Makefile.sources - sort the list(s) - bundle the scons buildscript v2: Don't double include the test sources. Signed-off-by: Emil Velikov <[email protected]> Acked-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/gallium/drivers/llvmpipe/Makefile.am')
-rw-r--r--src/gallium/drivers/llvmpipe/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/gallium/drivers/llvmpipe/Makefile.am b/src/gallium/drivers/llvmpipe/Makefile.am
index 3c318be9e82..0bd4282632a 100644
--- a/src/gallium/drivers/llvmpipe/Makefile.am
+++ b/src/gallium/drivers/llvmpipe/Makefile.am
@@ -36,6 +36,8 @@ libllvmpipe_la_SOURCES = $(C_SOURCES)
libllvmpipe_la_LDFLAGS = $(LLVM_LDFLAGS)
+noinst_HEADERS = lp_test.h
+
check_PROGRAMS = \
lp_test_format \
lp_test_arit \
@@ -72,3 +74,4 @@ lp_test_printf_SOURCES = lp_test_printf.c lp_test_main.c
lp_test_printf_LDADD = $(TEST_LIBS)
nodist_EXTRA_lp_test_printf_SOURCES = dummy.cpp
+EXTRA_DIST = SConscript