summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/lima/meson.build
diff options
context:
space:
mode:
authorConnor Abbott <[email protected]>2017-11-03 17:34:32 -0400
committerConnor Abbott <[email protected]>2019-07-18 14:33:23 +0200
commitcc78a425772a377c309fe1a9cb02186a834621a8 (patch)
tree13d146a5534bce980700805a47e7bd3b6d7393a5 /src/gallium/drivers/lima/meson.build
parent4423552ff04647aae75dc2cc0dc0ce580b80b3a3 (diff)
lima: Reintroduce the standalone compiler
I used this to test things without needing to have a device handy. Acked-by: Qiang Yu <[email protected]>
Diffstat (limited to 'src/gallium/drivers/lima/meson.build')
-rw-r--r--src/gallium/drivers/lima/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/gallium/drivers/lima/meson.build b/src/gallium/drivers/lima/meson.build
index b6a197fcc8d..1db8c7ea8f9 100644
--- a/src/gallium/drivers/lima/meson.build
+++ b/src/gallium/drivers/lima/meson.build
@@ -86,3 +86,29 @@ driver_lima = declare_dependency(
link_with : [liblima, liblimawinsys, libpanfrost_shared],
dependencies : idep_nir,
)
+
+
+lima_compiler = executable(
+ 'lima_compiler',
+ files(
+ 'standalone/lima_compiler_cmdline.c',
+ 'standalone/glsl.cpp'
+ ),
+ include_directories : [
+ inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_gallium_drivers, inc_mesa, inc_mapi, inc_compiler,
+ ],
+ dependencies : [
+ dep_thread,
+ idep_nir,
+ ],
+ link_with : [
+ liblima,
+ libgallium,
+ libglsl_standalone,
+ libmesa_util,
+ libpanfrost_shared,
+ ],
+ build_by_default : with_tools.contains('lima'),
+ install : with_tools.contains('lima'),
+)
+