summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/lima/meson.build
diff options
context:
space:
mode:
authorQiang Yu <[email protected]>2019-03-12 13:49:26 -0600
committerQiang Yu <[email protected]>2019-04-11 09:57:53 +0800
commit92d7ca4b1cdfe1ffc80748fa7eedf927f3c664f0 (patch)
treed96651839bae0342e65b9cd414e56759a9a25cea /src/gallium/drivers/lima/meson.build
parent64eaf60ca739704f71bd312c0f4039d287258216 (diff)
gallium: add lima driver
v2: - use renamed util_dynarray_grow_cap - use DEBUG_GET_ONCE_FLAGS_OPTION for debug flags - remove DRM_FORMAT_MOD_ARM_AGTB_MODE0 usage - compute min/max index in driver v3: - fix plbu framebuffer state calculation - fix color_16pc assemble - use nir_lower_all_source_mods for lowering neg/abs/sat - use float arrary for static GPU data - add disassemble comment for static shader code - use drm_find_modifier v4: - use lima_nir_lower_uniform_to_scalar v5: - remove nir_opt_global_to_local when rebase Cc: Rob Clark <[email protected]> Cc: Alyssa Rosenzweig <[email protected]> Acked-by: Eric Anholt <[email protected]> Signed-off-by: Andreas Baierl <[email protected]> Signed-off-by: Arno Messiaen <[email protected]> Signed-off-by: Connor Abbott <[email protected]> Signed-off-by: Erico Nunes <[email protected]> Signed-off-by: Heiko Stuebner <[email protected]> Signed-off-by: Koen Kooi <[email protected]> Signed-off-by: Marek Vasut <[email protected]> Signed-off-by: marmeladema <[email protected]> Signed-off-by: Paweł Chmiel <[email protected]> Signed-off-by: Rob Herring <[email protected]> Signed-off-by: Rohan Garg <[email protected]> Signed-off-by: Vasily Khoruzhick <[email protected]> Signed-off-by: Qiang Yu <[email protected]>
Diffstat (limited to 'src/gallium/drivers/lima/meson.build')
-rw-r--r--src/gallium/drivers/lima/meson.build89
1 files changed, 89 insertions, 0 deletions
diff --git a/src/gallium/drivers/lima/meson.build b/src/gallium/drivers/lima/meson.build
new file mode 100644
index 00000000000..a05f0e275ed
--- /dev/null
+++ b/src/gallium/drivers/lima/meson.build
@@ -0,0 +1,89 @@
+# Copyright © 2018 Lima Project
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+files_lima = files(
+ 'ir/gp/gpir.h',
+ 'ir/gp/nir.c',
+ 'ir/gp/node.c',
+ 'ir/gp/lower.c',
+ 'ir/gp/scheduler.c',
+ 'ir/gp/instr.c',
+ 'ir/gp/codegen.h',
+ 'ir/gp/codegen.c',
+ 'ir/gp/reduce_scheduler.c',
+ 'ir/gp/value_regalloc.c',
+ 'ir/gp/physical_regalloc.c',
+ 'ir/gp/disasm.c',
+
+ 'ir/pp/ppir.h',
+ 'ir/pp/nir.c',
+ 'ir/pp/node.c',
+ 'ir/pp/lower.c',
+ 'ir/pp/scheduler.c',
+ 'ir/pp/instr.c',
+ 'ir/pp/regalloc.c',
+ 'ir/pp/codegen.h',
+ 'ir/pp/codegen.c',
+ 'ir/pp/node_to_instr.c',
+ 'ir/pp/disasm.c',
+
+ 'ir/lima_nir_lower_uniform_to_scalar.c',
+
+ 'ir/lima_ir.h',
+
+ 'lima_screen.c',
+ 'lima_screen.h',
+ 'lima_context.c',
+ 'lima_context.h',
+ 'lima_resource.c',
+ 'lima_resource.h',
+ 'lima_state.c',
+ 'lima_draw.c',
+ 'lima_program.c',
+ 'lima_query.c',
+ 'lima_bo.c',
+ 'lima_bo.h',
+ 'lima_submit.c',
+ 'lima_submit.h',
+ 'lima_util.c',
+ 'lima_util.h',
+ 'lima_texture.c',
+ 'lima_texture.h',
+ 'lima_fence.c',
+ 'lima_fence.h',
+ 'lima_tiling.c',
+ 'lima_tiling.h',
+)
+
+liblima = static_library(
+ 'lima',
+ files_lima,
+ include_directories : [
+ inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_gallium_drivers,
+ ],
+ dependencies : [dep_libdrm, idep_nir_headers],
+)
+
+driver_lima = declare_dependency(
+ compile_args : '-DGALLIUM_LIMA',
+ link_with : [liblima, liblimawinsys],
+ dependencies : idep_nir,
+)