summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/lima/meson.build
diff options
context:
space:
mode:
authorVasily Khoruzhick <[email protected]>2019-08-05 12:33:09 -0700
committerVasily Khoruzhick <[email protected]>2019-08-06 17:49:22 +0000
commit5adfc8602c639827af0ba9a1059bd165a3ae49e7 (patch)
tree4763df43b93b9f7dcb990b59e2dccafe426ba220 /src/gallium/drivers/lima/meson.build
parent954224b7147e8197555856d9833e8cfb2342d4d5 (diff)
lima/ppir: move sin/cos input scaling into NIR
Reviewed-by: Erico Nunes <[email protected]> Signed-off-by: Vasily Khoruzhick <[email protected]>
Diffstat (limited to 'src/gallium/drivers/lima/meson.build')
-rw-r--r--src/gallium/drivers/lima/meson.build14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/gallium/drivers/lima/meson.build b/src/gallium/drivers/lima/meson.build
index 36788ddf0dd..2ab2b2ae118 100644
--- a/src/gallium/drivers/lima/meson.build
+++ b/src/gallium/drivers/lima/meson.build
@@ -70,9 +70,21 @@ files_lima = files(
'lima_fence.h',
)
+lima_nir_algebraic_c = custom_target(
+ 'ir/lima_nir_algebraic.c',
+ input : 'ir/lima_nir_algebraic.py',
+ output : 'lima_nir_algebraic.c',
+ command : [
+ prog_python, '@INPUT@',
+ '-p', join_paths(meson.source_root(), 'src/compiler/nir/'),
+ ],
+ capture : true,
+ depend_files : nir_algebraic_py,
+)
+
liblima = static_library(
'lima',
- files_lima,
+ files_lima, lima_nir_algebraic_c,
include_directories : [
inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_gallium_drivers,
inc_panfrost