aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/iris/meson.build
diff options
context:
space:
mode:
authorMark Janes <[email protected]>2019-04-22 11:43:12 -0700
committerMark Janes <[email protected]>2019-08-09 19:28:03 -0700
commit0fd4359733e6920d5cac9596eeada753a587a246 (patch)
tree7c501737149b0fa19bd80ae7fbae7ff3593e8c8b /src/gallium/drivers/iris/meson.build
parente4aa0fc63a86be6f5e1015db66d6a4682b7d6876 (diff)
iris/perf: implement routines to return counter info
With this commit, Iris will report that AMD_performance_monitor is supported, and will allow the caller to query the available metrics. Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/gallium/drivers/iris/meson.build')
-rw-r--r--src/gallium/drivers/iris/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/gallium/drivers/iris/meson.build b/src/gallium/drivers/iris/meson.build
index a953524a643..3f611c2b569 100644
--- a/src/gallium/drivers/iris/meson.build
+++ b/src/gallium/drivers/iris/meson.build
@@ -37,6 +37,7 @@ files_libiris = files(
'iris_formats.c',
'iris_genx_macros.h',
'iris_genx_protos.h',
+ 'iris_monitor.c',
'iris_pipe.h',
'iris_pipe_control.c',
'iris_program.c',
@@ -89,7 +90,7 @@ libiris = static_library(
dependencies : [dep_libdrm, dep_valgrind, idep_genxml, idep_libintel_common],
link_with : [
iris_gen_libs, libintel_compiler, libintel_dev, libisl,
- libblorp
+ libblorp, libintel_perf
],
)