summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/galahad/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2013-06-05 23:42:16 +0100
committerTom Stellard <[email protected]>2013-10-01 07:29:50 -0700
commit1918c37008e1c0ab163555034767b799e1aa63bc (patch)
tree67c472821cdc4bc6863fc0397948c1faf3580715 /src/gallium/drivers/galahad/Makefile.am
parent38d80c01d0a00148989f84631707ade9dc52e8e3 (diff)
galahad: consolidate C sources list into Makefile.sources
Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/drivers/galahad/Makefile.am')
-rw-r--r--src/gallium/drivers/galahad/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/gallium/drivers/galahad/Makefile.am b/src/gallium/drivers/galahad/Makefile.am
new file mode 100644
index 00000000000..5f64b93ceaf
--- /dev/null
+++ b/src/gallium/drivers/galahad/Makefile.am
@@ -0,0 +1,16 @@
+################################################################################
+
+# Meta-driver which combines whichever software rasterizers have been
+# built into a single convenience library.
+
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/src/gallium/drivers \
+ $(GALLIUM_CFLAGS) \
+ $(VISIBILITY_CFLAGS)
+
+noinst_LTLIBRARIES = libgalahad.la
+
+libgalahad_la_SOURCES = $(C_SOURCES)