summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/freedreno/meson.build
diff options
context:
space:
mode:
authorJonathan Marek <[email protected]>2018-12-18 20:15:57 -0500
committerRob Clark <[email protected]>2019-01-22 14:45:03 +0000
commit67610a0323ddfe0d7cced121abb43286b862b495 (patch)
tree994887050ff640f4c2db9f56ec55688d2f1412a4 /src/gallium/drivers/freedreno/meson.build
parentda3ca69afadb142c1591c75c2bfd345c8d4337de (diff)
freedreno: a2xx: NIR backend
This patch replaces the a2xx TGSI compiler with a NIR compiler. It also adds several new features: -gl_FrontFacing, gl_FragCoord, gl_PointCoord, gl_PointSize -control flow (including loops) -texture related features (LOD/bias, cubemaps) -filling scalar ALU slot when possible Signed-off-by: Jonathan Marek <[email protected]>
Diffstat (limited to 'src/gallium/drivers/freedreno/meson.build')
-rw-r--r--src/gallium/drivers/freedreno/meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/gallium/drivers/freedreno/meson.build b/src/gallium/drivers/freedreno/meson.build
index 7afdf5a746f..40b55ad491d 100644
--- a/src/gallium/drivers/freedreno/meson.build
+++ b/src/gallium/drivers/freedreno/meson.build
@@ -60,8 +60,6 @@ files_libfreedreno = files(
'a2xx/disasm-a2xx.c',
'a2xx/fd2_blend.c',
'a2xx/fd2_blend.h',
- 'a2xx/fd2_compiler.c',
- 'a2xx/fd2_compiler.h',
'a2xx/fd2_context.c',
'a2xx/fd2_context.h',
'a2xx/fd2_draw.c',
@@ -85,8 +83,12 @@ files_libfreedreno = files(
'a2xx/fd2_zsa.c',
'a2xx/fd2_zsa.h',
'a2xx/instr-a2xx.h',
- 'a2xx/ir-a2xx.c',
- 'a2xx/ir-a2xx.h',
+ 'a2xx/ir2.c',
+ 'a2xx/ir2.h',
+ 'a2xx/ir2_assemble.c',
+ 'a2xx/ir2_nir.c',
+ 'a2xx/ir2_private.h',
+ 'a2xx/ir2_ra.c',
'a3xx/fd3_blend.c',
'a3xx/fd3_blend.h',
'a3xx/fd3_context.c',