summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/freedreno/Makefile.am
diff options
context:
space:
mode:
authorRob Clark <[email protected]>2018-11-11 10:10:46 -0500
committerRob Clark <[email protected]>2018-11-27 15:44:02 -0500
commitb4476138d5ad3f8d30c14ee61f2f375edfdbab2a (patch)
tree023f9d60e21ad74aa341bf49cfd07a4cb5ed5a03 /src/gallium/drivers/freedreno/Makefile.am
parent6cb74eb4f1499d6e319a1c96d16174038e22540d (diff)
freedreno: move drm to common location
So that we can re-use at least parts of it for vulkan driver, and so that we can move ir3 to a common location (which uses fd_bo to allocate storage for shaders) Signed-off-by: Rob Clark <[email protected]>
Diffstat (limited to 'src/gallium/drivers/freedreno/Makefile.am')
-rw-r--r--src/gallium/drivers/freedreno/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/gallium/drivers/freedreno/Makefile.am b/src/gallium/drivers/freedreno/Makefile.am
index 5690b6ec884..39887e13e37 100644
--- a/src/gallium/drivers/freedreno/Makefile.am
+++ b/src/gallium/drivers/freedreno/Makefile.am
@@ -4,11 +4,10 @@ include $(top_srcdir)/src/gallium/Automake.inc
AM_CFLAGS = \
-Wno-packed-bitfield-compat \
-I$(top_srcdir)/src/gallium/drivers/freedreno/ir3 \
+ -I$(top_srcdir)/src/freedreno \
-I$(top_builddir)/src/compiler/nir \
-I$(top_srcdir)/src/compiler/nir \
- $(GALLIUM_DRIVER_CFLAGS) \
- $(LIBDRM_CFLAGS) \
- $(VALGRIND_CFLAGS)
+ $(GALLIUM_DRIVER_CFLAGS)
MKDIR_GEN = $(AM_V_at)$(MKDIR_P) $(@D)
ir3/ir3_nir_trig.c: ir3/ir3_nir_trig.py $(top_srcdir)/src/compiler/nir/nir_algebraic.py
@@ -19,7 +18,6 @@ noinst_LTLIBRARIES = libfreedreno.la
libfreedreno_la_SOURCES = \
$(C_SOURCES) \
- $(drm_SOURCES) \
$(a2xx_SOURCES) \
$(a3xx_SOURCES) \
$(a4xx_SOURCES) \
@@ -46,7 +44,7 @@ ir3_compiler_LDADD = \
$(top_builddir)/src/compiler/glsl/libstandalone.la \
$(top_builddir)/src/util/libmesautil.la \
$(top_builddir)/src/mesa/libmesagallium.la \
- $(GALLIUM_COMMON_LIB_DEPS) \
- $(LIBDRM_LIBS)
+ $(top_builddir)/src/freedreno/libfreedreno_drm.la \
+ $(GALLIUM_COMMON_LIB_DEPS)
EXTRA_DIST += meson.build