summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/freedreno/Makefile.am
diff options
context:
space:
mode:
authorRob Clark <[email protected]>2017-10-14 13:00:28 -0400
committerRob Clark <[email protected]>2017-10-24 15:33:40 -0400
commit0ca8d53215a8e2991430dbcbc13fbaf5b442318c (patch)
tree79ecc573fa65d30498e3821c4049d34edaec9145 /src/gallium/drivers/freedreno/Makefile.am
parent583ce96c9429e23c33daeb7025210ef73ae51688 (diff)
freedreno/ir3: use a flag instead of setting PYTHONPATH
Similar to 848da662224326ccfbe6647bc82f4f89ca22c762, pass an arg to ir3_nir_trig.py to add to python path, rather than using $PYTHONPATH, to prep for meson build support. Signed-off-by: Rob Clark <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/gallium/drivers/freedreno/Makefile.am')
-rw-r--r--src/gallium/drivers/freedreno/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gallium/drivers/freedreno/Makefile.am b/src/gallium/drivers/freedreno/Makefile.am
index 128c7fb5990..5cb4c74cb68 100644
--- a/src/gallium/drivers/freedreno/Makefile.am
+++ b/src/gallium/drivers/freedreno/Makefile.am
@@ -12,7 +12,7 @@ AM_CFLAGS = \
MKDIR_GEN = $(AM_V_at)$(MKDIR_P) $(@D)
ir3/ir3_nir_trig.c: ir3/ir3_nir_trig.py $(top_srcdir)/src/compiler/nir/nir_algebraic.py
$(MKDIR_GEN)
- $(AM_V_GEN) PYTHONPATH=$(top_srcdir)/src/compiler/nir $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/ir3/ir3_nir_trig.py > $@ || ($(RM) $@; false)
+ $(AM_V_GEN) $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/ir3/ir3_nir_trig.py -p $(top_srcdir)/src/compiler/nir > $@ || ($(RM) $@; false)
noinst_LTLIBRARIES = libfreedreno.la