summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/freedreno/Makefile.am
diff options
context:
space:
mode:
authorRob Clark <[email protected]>2016-04-23 09:03:28 -0400
committerRob Clark <[email protected]>2016-04-25 16:16:21 -0400
commit4610e5ef28e4f209617c3cabf5a2dd699e52cc33 (patch)
treec6e4fa97c4ce6b1b712b03da7e55d67f9ac8ee02 /src/gallium/drivers/freedreno/Makefile.am
parent21b4bcdd05eabe94feb1a17bbb96f55d26eabe6e (diff)
freedreno/ir3: fix sin/cos
We seem to need range reduction to get sane results. Fixes glmark2 jellyfish bench, and a whole bunch of dEQP-GLES3.functional.shaders.builtin_functions.precision.{sin,cos,tan}.* v2: squashed in android build fixes from Rob Herring Signed-off-by: Rob Clark <[email protected]>
Diffstat (limited to 'src/gallium/drivers/freedreno/Makefile.am')
-rw-r--r--src/gallium/drivers/freedreno/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/gallium/drivers/freedreno/Makefile.am b/src/gallium/drivers/freedreno/Makefile.am
index 329a4204c3a..9c0ccdf1eca 100644
--- a/src/gallium/drivers/freedreno/Makefile.am
+++ b/src/gallium/drivers/freedreno/Makefile.am
@@ -5,9 +5,14 @@ AM_CFLAGS = \
-Wno-packed-bitfield-compat \
-I$(top_srcdir)/src/gallium/drivers/freedreno/ir3 \
-I$(top_builddir)/src/compiler/nir \
+ -I$(top_srcdir)/src/compiler/nir \
$(GALLIUM_DRIVER_CFLAGS) \
$(FREEDRENO_CFLAGS)
+ir3/ir3_nir_trig.c: ir3/ir3_nir_trig.py $(top_srcdir)/src/compiler/nir/nir_algebraic.py
+ $(MKDIR_GEN)
+ $(AM_V_GEN) PYTHONPATH=$(top_srcdir)/src/compiler/nir $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/ir3/ir3_nir_trig.py > $@ || ($(RM) $@; false)
+
noinst_LTLIBRARIES = libfreedreno.la
libfreedreno_la_SOURCES = \
@@ -15,7 +20,11 @@ libfreedreno_la_SOURCES = \
$(a2xx_SOURCES) \
$(a3xx_SOURCES) \
$(a4xx_SOURCES) \
- $(ir3_SOURCES)
+ $(ir3_SOURCES) \
+ $(ir3_GENERATED_FILES)
+
+BUILT_SOURCES := $(ir3_GENERATED_FILES)
+CLEANFILES := $(BUILT_SOURCES)
noinst_PROGRAMS = ir3_compiler