summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/freedreno/Makefile.am
diff options
context:
space:
mode:
authorIlia Mirkin <[email protected]>2014-09-15 21:42:01 -0400
committerRob Clark <[email protected]>2014-09-16 12:13:22 -0400
commita420aa1b4183e06bbbb6d909663ccb1e4527f096 (patch)
tree69eacbc1875f161a24cf44dc19d08f857333a981 /src/gallium/drivers/freedreno/Makefile.am
parent5b1d316c514d75c346ce18dacb05a7c3ef2e41b2 (diff)
freedreno: add a standalone ir3_compiler binary for building TGSI
Compiler taken from the combo old/new compiler comparer + simulator. Signed-off-by: Ilia Mirkin <[email protected]>
Diffstat (limited to 'src/gallium/drivers/freedreno/Makefile.am')
-rw-r--r--src/gallium/drivers/freedreno/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/gallium/drivers/freedreno/Makefile.am b/src/gallium/drivers/freedreno/Makefile.am
index 33563f5952b..ee5d506f2a3 100644
--- a/src/gallium/drivers/freedreno/Makefile.am
+++ b/src/gallium/drivers/freedreno/Makefile.am
@@ -17,4 +17,16 @@ libfreedreno_la_SOURCES = \
$(a3xx_SOURCES) \
$(ir3_SOURCES)
+noinst_PROGRAMS = ir3_compiler
+
+ir3_compiler_SOURCES = \
+ ir3/ir3_cmdline.c
+
+ir3_compiler_LDADD = \
+ libfreedreno.la \
+ ../../auxiliary/libgallium.la \
+ $(top_builddir)/src/util/libmesautil.la \
+ $(GALLIUM_COMMON_LIB_DEPS) \
+ $(FREEDRENO_LIBS)
+
EXTRA_DIST = Android.mk