summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/freedreno/Makefile.am
diff options
context:
space:
mode:
authorRob Clark <[email protected]>2012-10-27 11:07:34 -0500
committerRob Clark <[email protected]>2013-03-11 21:53:24 -0400
commit6173cc19c45d92ef0b7bc6aa008aa89bb29abbda (patch)
tree50b2d2fca779e88ad8f143d08901dfb01fc36096 /src/gallium/drivers/freedreno/Makefile.am
parent44a8e5135470fa51ae36b304f3c5286bf9cca259 (diff)
freedreno: gallium driver for adreno
Currently works on a220. Others in the a2xx family look pretty similar and should be pretty straightforward to support with the same driver. The a3xx has a new shader ISA, and while many registers appear similar, the register addresses have been completely shuffled around. I am not sure yet whether it is best to support with the same driver, but different compiler, or whether it should be split into a different driver. v1: original v2: build file updates from review comments, and remove GPL licensed header files from msm kernel v3: smarter temp/pred register assignment, fix clear and depth/stencil format issues, resource_transfer fixes, scissor fixes Signed-off-by: Rob Clark <[email protected]>
Diffstat (limited to 'src/gallium/drivers/freedreno/Makefile.am')
-rw-r--r--src/gallium/drivers/freedreno/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/gallium/drivers/freedreno/Makefile.am b/src/gallium/drivers/freedreno/Makefile.am
new file mode 100644
index 00000000000..9bb532dc181
--- /dev/null
+++ b/src/gallium/drivers/freedreno/Makefile.am
@@ -0,0 +1,32 @@
+include $(top_srcdir)/src/gallium/Automake.inc
+
+noinst_LTLIBRARIES = libfreedreno.la
+
+AM_CFLAGS = \
+ -Wno-packed-bitfield-compat \
+ -I$(top_srcdir)/src/gallium/drivers \
+ $(GALLIUM_CFLAGS) \
+ $(FREEDRENO_CFLAGS) \
+ $(PIC_FLAGS) \
+ $(VISIBILITY_CFLAGS)
+
+libfreedreno_la_SOURCES = \
+ freedreno_util.c \
+ freedreno_fence.c \
+ freedreno_resource.c \
+ freedreno_surface.c \
+ freedreno_vbo.c \
+ freedreno_blend.c \
+ freedreno_rasterizer.c \
+ freedreno_zsa.c \
+ freedreno_state.c \
+ freedreno_clear.c \
+ freedreno_program.c \
+ freedreno_texture.c \
+ freedreno_context.c \
+ freedreno_screen.c \
+ freedreno_gmem.c \
+ freedreno_compiler.c \
+ ir.c \
+ disasm.c
+