summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/etnaviv/meson.build
diff options
context:
space:
mode:
authorWladimir J. van der Laan <[email protected]>2017-11-18 10:44:31 +0100
committerChristian Gmeiner <[email protected]>2017-11-30 07:27:57 +0100
commitdd3a04c2c3303e47beff0d8f66e7501790e845ed (patch)
tree1216336bcb9df0cb94a48f66469fd07abfdeb257 /src/gallium/drivers/etnaviv/meson.build
parent079bbaec0c7a0ef984ce502fb86f980cbe8577f8 (diff)
etnaviv: GC7000: BLT engine blitting support
Add an implemenation of key clear_blit functions using the BLT engine that replaced the RS on GC7000. Also set level->size correctly for imported resources. This is important for the BLT resolve-in-place path to work for them. Signed-off-by: Wladimir J. van der Laan <[email protected]> Reviewed-by: Christian Gmeiner <[email protected]>
Diffstat (limited to 'src/gallium/drivers/etnaviv/meson.build')
-rw-r--r--src/gallium/drivers/etnaviv/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/gallium/drivers/etnaviv/meson.build b/src/gallium/drivers/etnaviv/meson.build
index b9c5e47d197..f9128ae0d50 100644
--- a/src/gallium/drivers/etnaviv/meson.build
+++ b/src/gallium/drivers/etnaviv/meson.build
@@ -24,11 +24,14 @@ files_etnaviv = files(
'hw/common_3d.xml.h',
'hw/isa.xml.h',
'hw/state_3d.xml.h',
+ 'hw/state_blt.xml.h',
'hw/state.xml.h',
'etnaviv_asm.c',
'etnaviv_asm.h',
'etnaviv_blend.c',
'etnaviv_blend.h',
+ 'etnaviv_blt.c',
+ 'etnaviv_blt.h',
'etnaviv_clear_blit.c',
'etnaviv_clear_blit.h',
'etnaviv_compiler.c',