summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/Makefile.am
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2012-03-03 20:02:05 -0500
committerTom Stellard <[email protected]>2012-03-14 10:25:59 -0400
commit26ab747284e0d7ec5ef039c6ab3d50c3fab42ac4 (patch)
tree34d565b3ef252f1b928dda17a4f5394f0e71d299 /src/gallium/drivers/Makefile.am
parentfe3f98ed70be01a49dd2e93870907d092fe4a283 (diff)
galahad: Use non-recursive automake
Diffstat (limited to 'src/gallium/drivers/Makefile.am')
-rw-r--r--src/gallium/drivers/Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/src/gallium/drivers/Makefile.am b/src/gallium/drivers/Makefile.am
index b6954e2d94a..6a0a2472c16 100644
--- a/src/gallium/drivers/Makefile.am
+++ b/src/gallium/drivers/Makefile.am
@@ -1,4 +1,31 @@
-SUBDIRS = $(GALLIUM_DRIVERS_DIRS)
+AUTOMAKE_OPTIONS = subdir-objects
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/gallium/include \
+ -I$(top_srcdir)/src/gallium/auxiliary \
+ -I$(top_srcdir)/src/gallium/drivers \
+ $(DEFINES) \
+ $(ASM_FLAGS) \
+ $(PIC_FLAGS)
+
+noinst_LIBRARIES =
+
+################################################################################
+
+if HAVE_GALAHAD_GALLIUM
+
+noinst_LIBRARIES+= galahad/libgalahad.a
+
+galahad_libgalahad_a_SOURCES = \
+ galahad/glhd_objects.c \
+ galahad/glhd_context.c \
+ galahad/glhd_screen.c
+
+endif
+
+################################################################################
+
+SUBDIRS = $(GALLIUM_MAKE_DIRS)
# FIXME: Remove when the rest of Gallium is converted to automake.
default: all