aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/pipe-loader/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-10-14 16:37:37 +0100
committerEmil Velikov <[email protected]>2015-11-21 12:52:18 +0000
commit74d41a32bc179425e866f8afa33a222488ea7760 (patch)
tree7f3c766ab1585845c4bb7b635d698adaebcb4427 /src/gallium/auxiliary/pipe-loader/Makefile.am
parentcbc4d9730a7c48744fe7ac62d55b40a80e8fc2e2 (diff)
gallium: remove library_path argument from pipe_loader_create_screen()
Currently the location is determined at configure/build time and consistently copied across gallium. Just remove the extra argument, and use PIPE_SEARCH_DIR where appropriate. This will allow us to remove the duplication in the *configuration and *screen_create APIs by moving util_dl_get_proc_address() and friends to probe time. v2: rebase on top of vl_winsys_drm.c addition Signed-off-by: Emil Velikov <[email protected]> Acked-by: Rob Clark <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/pipe-loader/Makefile.am')
-rw-r--r--src/gallium/auxiliary/pipe-loader/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gallium/auxiliary/pipe-loader/Makefile.am b/src/gallium/auxiliary/pipe-loader/Makefile.am
index e12620c4418..1597b79598e 100644
--- a/src/gallium/auxiliary/pipe-loader/Makefile.am
+++ b/src/gallium/auxiliary/pipe-loader/Makefile.am
@@ -5,6 +5,7 @@ include $(top_srcdir)/src/gallium/Automake.inc
AM_CFLAGS = \
-I$(top_srcdir)/src/loader \
-I$(top_srcdir)/src/gallium/winsys \
+ -DPIPE_SEARCH_DIR=\"$(libdir)/gallium-pipe\" \
$(GALLIUM_PIPE_LOADER_DEFINES) \
$(GALLIUM_CFLAGS) \
$(VISIBILITY_CFLAGS)