summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/pipe-loader/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-01-11 04:28:24 +0000
committerEmil Velikov <[email protected]>2014-01-18 18:47:49 +0000
commita0a1c60fb0137804e6abf403898468fe103ec382 (patch)
tree6641798abdce75dde21a0797c3ea3c0c3960945e /src/gallium/auxiliary/pipe-loader/Makefile.am
parent0e78c3523427190d649b02f586a6554889d74c2f (diff)
pipe-loader: use loader util lib
Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Rob Clark <[email protected]> Reviewed-by: Kristian Høgsberg <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/pipe-loader/Makefile.am')
-rw-r--r--src/gallium/auxiliary/pipe-loader/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/gallium/auxiliary/pipe-loader/Makefile.am b/src/gallium/auxiliary/pipe-loader/Makefile.am
index 54034472ca0..8e4d0349f6b 100644
--- a/src/gallium/auxiliary/pipe-loader/Makefile.am
+++ b/src/gallium/auxiliary/pipe-loader/Makefile.am
@@ -20,7 +20,12 @@ libpipe_loader_la_SOURCES = \
pipe_loader_sw.c
if HAVE_DRM_LOADER_GALLIUM
-libpipe_loader_la_SOURCES += pipe_loader_drm.c
AM_CFLAGS = $(LIBDRM_CFLAGS)
+
+libpipe_loader_la_SOURCES += pipe_loader_drm.c
+
+libpipe_loader_la_LIBADD = \
+ $(top_builddir)/src/loader/libloader.la
+
endif
endif