summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/pipe-loader/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <[email protected]>2015-08-14 17:25:04 -0700
committerJason Ekstrand <[email protected]>2015-08-17 11:25:03 -0700
commit6a7ca4ef2cd3f39d3b5e77051cb3f3175e9e60df (patch)
treed5413781ac9e9ecfc22cf403fa7465d6a7cadb34 /src/gallium/auxiliary/pipe-loader/Makefile.am
parentb4c02253c4e1a7bc5a7a6369045210932f5de605 (diff)
parentd3e23f1ff915c01541f8df375b50b93b3da565a8 (diff)
Merge remote-tracking branch 'mesa-public/master' into vulkan
Diffstat (limited to 'src/gallium/auxiliary/pipe-loader/Makefile.am')
-rw-r--r--src/gallium/auxiliary/pipe-loader/Makefile.am39
1 files changed, 15 insertions, 24 deletions
diff --git a/src/gallium/auxiliary/pipe-loader/Makefile.am b/src/gallium/auxiliary/pipe-loader/Makefile.am
index cb6035d85c9..8c837996539 100644
--- a/src/gallium/auxiliary/pipe-loader/Makefile.am
+++ b/src/gallium/auxiliary/pipe-loader/Makefile.am
@@ -1,37 +1,28 @@
include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
-AM_CPPFLAGS = $(DEFINES) \
- $(VISIBILITY_CFLAGS) \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/src \
+# XXX: check if we need the gallium/winsys include
+AM_CFLAGS = \
-I$(top_srcdir)/src/loader \
- -I$(top_srcdir)/src/gallium/include \
- -I$(top_srcdir)/src/gallium/auxiliary \
- -I$(top_srcdir)/src/gallium/winsys
+ -I$(top_srcdir)/src/gallium/winsys \
+ $(GALLIUM_PIPE_LOADER_DEFINES) \
+ $(GALLIUM_CFLAGS) \
+ $(VISIBILITY_CFLAGS)
noinst_LTLIBRARIES = libpipe_loader.la
-noinst_LTLIBRARIES += libpipe_loader_client.la
+
+libpipe_loader_la_SOURCES = \
+ $(COMMON_SOURCES)
if HAVE_DRM_LOADER_GALLIUM
-AM_CFLAGS = $(LIBDRM_CFLAGS)
+AM_CFLAGS += \
+ $(LIBDRM_CFLAGS)
-COMMON_SOURCES += $(DRM_SOURCES)
+libpipe_loader_la_SOURCES += \
+ $(DRM_SOURCES)
-COMMON_LIBADD = \
+libpipe_loader_la_LIBADD = \
$(top_builddir)/src/loader/libloader.la
endif
-libpipe_loader_la_CFLAGS = \
- $(GALLIUM_PIPE_LOADER_DEFINES) \
- $(AM_CFLAGS) $(AM_CPPFLAGS)
-libpipe_loader_la_SOURCES = $(COMMON_SOURCES)
-libpipe_loader_la_LIBADD = $(COMMON_LIBADD) \
- $(GALLIUM_PIPE_LOADER_LIBS)
-
-libpipe_loader_client_la_CFLAGS = \
- $(GALLIUM_PIPE_LOADER_CLIENT_DEFINES) \
- $(AM_CFLAGS) $(AM_CPPFLAGS)
-libpipe_loader_client_la_SOURCES = $(COMMON_SOURCES)
-libpipe_loader_client_la_LIBADD = $(COMMON_LIBADD) \
- $(GALLIUM_PIPE_LOADER_CLIENT_LIBS)