aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/pipe-loader/Makefile.am
diff options
context:
space:
mode:
authorFrancisco Jerez <[email protected]>2012-04-25 22:16:00 +0200
committerFrancisco Jerez <[email protected]>2012-05-11 12:39:43 +0200
commite1364530622a26f11c79694429cf84418a0b7ef7 (patch)
tree9de616021c489130ea64751659cb0622ebd991d3 /src/gallium/auxiliary/pipe-loader/Makefile.am
parent2faf01c8403514dda15ab8b1a2309d5529dd06ba (diff)
gallium: Add pipe loader for device enumeration and driver multiplexing.
The goal is to have a uniform interface to create winsys and pipe_screen instances for any driver, exposing the device enumeration capabilities that might be supported by the operating system (for now there's a "drm" back-end using udev and a "sw" back-end that always returns the same built-in devices). The typical use case of this library will be: > > struct pipe_loader_device devs[n]; > struct pipe_screen *screen; > > pipe_loader_probe(&devs, n); >[pick some device from the array...] > > screen = pipe_loader_create_screen(dev, library_search_path); >[do something with screen...] > > screen->destroy(screen); > pipe_loader_release(&devs, N); > A part of the code was taken from targets/gbm/pipe_loader.c, which will be removed and replaced with calls into this library by a future commit.
Diffstat (limited to 'src/gallium/auxiliary/pipe-loader/Makefile.am')
-rw-r--r--src/gallium/auxiliary/pipe-loader/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/gallium/auxiliary/pipe-loader/Makefile.am b/src/gallium/auxiliary/pipe-loader/Makefile.am
new file mode 100644
index 00000000000..c63dce3fe4a
--- /dev/null
+++ b/src/gallium/auxiliary/pipe-loader/Makefile.am
@@ -0,0 +1,38 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
+AM_CPPFLAGS = $(DEFINES) \
+ $(GALLIUM_PIPE_LOADER_DEFINES) \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/gallium/include \
+ -I$(top_srcdir)/src/gallium/auxiliary \
+ -I$(top_srcdir)/src/gallium/winsys
+
+AM_CFLAGS = $(PIC_FLAGS)
+
+noinst_LTLIBRARIES =
+
+if HAVE_LOADER_GALLIUM
+noinst_LTLIBRARIES += libpipe_loader.la
+
+libpipe_loader_la_SOURCES = \
+ pipe_loader.h \
+ pipe_loader_priv.h \
+ pipe_loader.c \
+ pipe_loader_sw.c
+
+if HAVE_DRM_LOADER_GALLIUM
+libpipe_loader_la_SOURCES += pipe_loader_drm.c
+AM_CFLAGS += $(LIBDRM_CFLAGS)
+endif
+
+# Provide compatibility with scripts for the old Mesa build system for
+# a while by putting a link to the library in the current directory.
+all-local: libpipe_loader.la
+ ln -f .libs/libpipe_loader.a .
+
+clean-local:
+ rm -f libpipe_loader.a
+endif
+
+# FIXME: Remove when the rest of Gallium is converted to automake.
+default: all