summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2019-06-27 15:05:31 -0700
committerEric Anholt <[email protected]>2019-11-14 10:47:20 -0800
commit882ca6dfb0f3d17e0f8bc917307d915ab1718069 (patch)
tree652b9932fc1182d4d191d7970fcd10c3687fbd3b /src/gallium/auxiliary/meson.build
parentac78ca4b39ce6e927f824b928d17f30c1d9273ce (diff)
util: Move gallium's PIPE_FORMAT utils to /util/format/
To make PIPE_FORMATs usable from non-gallium parts of Mesa, I want to move their helpers out of gallium. Since u_format used util_copy_rect(), I moved that in there, too. I've put it in a separate directory in util/ because it's a big chunk of related code, and it's not clear to me whether we might want it as a separate library from libmesa_util at some point. Closes: #1905 Acked-by: Marek Olšák <[email protected]> Reviewed-by: Kristian H. Kristensen <[email protected]> Reviewed-by: Alyssa Rosenzweig <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/meson.build')
-rw-r--r--src/gallium/auxiliary/meson.build31
1 files changed, 1 insertions, 30 deletions
diff --git a/src/gallium/auxiliary/meson.build b/src/gallium/auxiliary/meson.build
index c7ae8fd53e2..9ebfcea8624 100644
--- a/src/gallium/auxiliary/meson.build
+++ b/src/gallium/auxiliary/meson.build
@@ -264,26 +264,6 @@ files_libgallium = files(
'util/u_dump.h',
'util/u_dump_state.c',
'util/u_fifo.h',
- 'util/u_format.c',
- 'util/u_format.h',
- 'util/u_format_bptc.c',
- 'util/u_format_bptc.h',
- 'util/u_format_etc.c',
- 'util/u_format_etc.h',
- 'util/u_format_latc.c',
- 'util/u_format_latc.h',
- 'util/u_format_other.c',
- 'util/u_format_other.h',
- 'util/u_format_rgtc.c',
- 'util/u_format_rgtc.h',
- 'util/u_format_s3tc.c',
- 'util/u_format_s3tc.h',
- 'util/u_format_tests.c',
- 'util/u_format_tests.h',
- 'util/u_format_yuv.c',
- 'util/u_format_yuv.h',
- 'util/u_format_zs.c',
- 'util/u_format_zs.h',
'util/u_framebuffer.c',
'util/u_framebuffer.h',
'util/u_gen_mipmap.c',
@@ -508,18 +488,9 @@ u_unfilled_gen_c = custom_target(
capture : true,
)
-u_format_table_c = custom_target(
- 'u_format_table.c',
- input : ['util/u_format_table.py', 'util/u_format.csv'],
- output : 'u_format_table.c',
- command : [prog_python, '@INPUT@'],
- depend_files : files('util/u_format_pack.py', 'util/u_format_parse.py'),
- capture : true,
-)
-
libgallium = static_library(
'gallium',
- [files_libgallium, u_indices_gen_c, u_unfilled_gen_c, u_format_table_c],
+ [files_libgallium, u_indices_gen_c, u_unfilled_gen_c],
include_directories : [
inc_loader, inc_gallium, inc_src, inc_include, include_directories('util')
],