aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-11-27 00:25:28 +0000
committerEmil Velikov <[email protected]>2017-05-19 19:44:15 +0100
commitacf3d2afab0571b74c0c0d1aee0f631b33fdc7da (patch)
treea14f1e451c4f601340d0b2ab7063f72a98f1769e /src/gallium/auxiliary/Makefile.am
parent8212fc95b59d0dd3cae1fe11359e0fa96d75e1bc (diff)
configure: check once for DRI3 dependencies
Currently we are having the XCB_DRI3 dependencies duplicated, partially. Just do a once-off check and add all of the respective CFLAGS/LIBS where needed. As a nice side effect this helps us solve a couple of FIXMEs. DRI3 is not a thing w/o X11 so disable it in such cases. Cc: [email protected] Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
index dc4bd4a40cf..e25e31b89ea 100644
--- a/src/gallium/auxiliary/Makefile.am
+++ b/src/gallium/auxiliary/Makefile.am
@@ -72,6 +72,7 @@ if NEED_GALLIUM_VL
COMMON_VL_CFLAGS = \
$(AM_CFLAGS) \
$(VL_CFLAGS) \
+ $(XCB_DRI3_CFLAGS) \
$(DRI2PROTO_CFLAGS) \
$(LIBDRM_CFLAGS)