aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2017-09-04 22:36:34 +0200
committerMarek Olšák <[email protected]>2018-02-07 22:08:34 +0100
commit6f82b8d8d0a986aac28e7bec47fc313fb950475c (patch)
tree69eac15198a19e2e16447b5d4774a5c787af677e /src/gallium/auxiliary/Makefile.am
parentdef09f8db0ce77fc41f5188418e0b06356ce59b7 (diff)
gallium: build ddebug, noop, rbug, trace as part of auxiliary
Building gallium is faster by 7.5 seconds on a 4core/8thread 3GHz CPU. (gallium build time is reduced by 15% when building only radeonsi) Non-recursive makefiles are great!
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
index 95a325f96b3..7af3f3ce42a 100644
--- a/src/gallium/auxiliary/Makefile.am
+++ b/src/gallium/auxiliary/Makefile.am
@@ -1,4 +1,8 @@
include Makefile.sources
+include $(top_srcdir)/src/gallium/drivers/ddebug/Makefile.sources
+include $(top_srcdir)/src/gallium/drivers/noop/Makefile.sources
+include $(top_srcdir)/src/gallium/drivers/rbug/Makefile.sources
+include $(top_srcdir)/src/gallium/drivers/trace/Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
noinst_LTLIBRARIES = libgallium.la
@@ -19,7 +23,11 @@ AM_CXXFLAGS = \
libgallium_la_SOURCES = \
$(C_SOURCES) \
$(NIR_SOURCES) \
- $(GENERATED_SOURCES)
+ $(GENERATED_SOURCES) \
+ $(DDEBUG_SOURCES) \
+ $(NOOP_SOURCES) \
+ $(RBUG_SOURCES) \
+ $(TRACE_SOURCES)
if HAVE_LIBDRM