summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2012-08-24 11:48:32 -0700
committerAndreas Boll <[email protected]>2013-01-10 22:01:06 +0100
commit80d290d47ad6d29ab041d0da24ab8be1036b2e9d (patch)
treea0a116b57cda3bc786f6f2a75397cfc97a4ca9b7 /src/gallium/auxiliary/Makefile.am
parent047fe04750acdbc9e807bce955aa890e5d1fd268 (diff)
libgallium: Convert to automake
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
new file mode 100644
index 00000000000..c5b8c056006
--- /dev/null
+++ b/src/gallium/auxiliary/Makefile.am
@@ -0,0 +1,52 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+SUBDIRS += pipebuffer
+noinst_LTLIBRARIES = libgallium.la
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/src/gallium/auxiliary/util \
+ $(GALLIUM_CFLAGS)
+
+libgallium_la_SOURCES = \
+ $(C_SOURCES) \
+ $(GENERATED_SOURCES)
+
+if HAVE_MESA_LLVM
+
+AM_CFLAGS += \
+ $(LLVM_CFLAGS)
+
+AM_CXXFLAGS = \
+ $(GALLIUM_CFLAGS) \
+ $(LLVM_CXXFLAGS)
+
+if LLVM_NEEDS_FNORTTI
+
+AM_CXXFLAGS += -fno-rtti
+
+endif
+
+libgallium_la_SOURCES += \
+ $(GALLIVM_SOURCES) \
+ $(GALLIVM_CPP_SOURCES)
+
+endif
+
+indices/u_indices_gen.c: $(srcdir)/indices/u_indices_gen.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
+
+indices/u_unfilled_gen.c: $(srcdir)/indices/u_unfilled_gen.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
+
+util/u_format_srgb.c: $(srcdir)/util/u_format_srgb.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
+
+util/u_format_table.c: $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format_pack.py $(srcdir)/util/u_format_parse.py $(srcdir)/util/u_format.csv
+ $(AM_V_GEN) $(PYTHON2) $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format.csv > $@
+
+#XXX: Delete this when all targets are converted to automake.
+all-local: libgallium.la
+ ln -f $(builddir)/.libs/libgallium.a $(builddir)/libgallium.a