summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-05-02 17:53:17 +0100
committerEmil Velikov <[email protected]>2017-05-19 19:46:41 +0100
commit369e5dd939b4af6c653d6cbbe9be257a9c2c950e (patch)
treec30ed65c3c5d4c56c245d333f06f1f5aadfcc0dd /src/gallium/auxiliary/Makefile.am
parent05043e0e8e0bd5e3019f480557d452b4c165f8f2 (diff)
auxiliary/vl: use vl_*_screen_create stubs when building w/o platform
Provide a dummy stub when the user has opted w/o said platform, thus we can build the binaries without unnecessarily requiring X11/other headers. In order to avoid build and link-time issues, we remove the HAVE_DRI3 guards in the VA and VDPAU state-trackers. With this change st/va will return VA_STATUS_ERROR_ALLOCATION_FAILED instead of VA_STATUS_ERROR_UNIMPLEMENTED. That is fine since upstream users of libva such as vlc and mpv do little error checking, let alone distinguish between the two. Cc: Leo Liu <[email protected]> Cc: Guttula, Suresh <[email protected]> Cc: [email protected] Cc: Christian König <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
index e25e31b89ea..a64ead28e32 100644
--- a/src/gallium/auxiliary/Makefile.am
+++ b/src/gallium/auxiliary/Makefile.am
@@ -88,23 +88,24 @@ if NEED_GALLIUM_VL_WINSYS
noinst_LTLIBRARIES += libgalliumvlwinsys.la
-libgalliumvlwinsys_la_CFLAGS = \
- $(COMMON_VL_CFLAGS)
+libgalliumvlwinsys_la_CFLAGS = $(COMMON_VL_CFLAGS)
+libgalliumvlwinsys_la_SOURCES = $(VL_WINSYS_SOURCES)
-libgalliumvlwinsys_la_SOURCES = \
- $(VL_WINSYS_SOURCES)
+if HAVE_PLATFORM_X11
+libgalliumvlwinsys_la_SOURCES += $(VL_WINSYS_DRI2_SOURCES)
if HAVE_DRI3
-
-libgalliumvlwinsys_la_SOURCES += \
- $(VL_WINSYS_DRI3_SOURCES)
-
+libgalliumvlwinsys_la_SOURCES += $(VL_WINSYS_DRI3_SOURCES)
endif
-
endif
+if HAVE_PLATFORM_DRM
+libgalliumvlwinsys_la_SOURCES += $(VL_WINSYS_DRM_SOURCES)
endif
+endif # NEED_GALLIUM_VL_WINSYS
+endif # NEED_GALLIUM_VL
+
EXTRA_DIST = \
SConscript \
indices/u_indices.c \