summaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-11-16 01:07:32 +0000
committerEmil Velikov <[email protected]>2014-11-16 01:07:32 +0000
commitd936ef3fb75f2333f795e004204b87760e564b3f (patch)
tree6be5845249e8d1be0290f8934fd91b04f3f599d7 /src/gallium/auxiliary/Makefile.am
parentded56e467437b2ee33ee01405072cb1c63fb8764 (diff)
auxiliary: ship all files in the distribution tarball
- Add all headers into Makefile.sources - Don't forget the target-helpers - Add the python scripts & the formats table/list (csv) - Temporary add vl/vl_winsys_dri.c to EXTRA_DIST until we rework the way VL is build. - Add the following to EXTRA_DIST - they are included via the generated u_indices_gen.c thus we should not add them to *SOURCES. indices/u_indices.c indices/u_unfilled_indices.c XXX: Should we nuke gallivm/f.cpp ? It seems that no-one is using it. v2: Rebase Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/Makefile.am')
-rw-r--r--src/gallium/auxiliary/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
index 4d8ba89cc98..4b3ed920083 100644
--- a/src/gallium/auxiliary/Makefile.am
+++ b/src/gallium/auxiliary/Makefile.am
@@ -46,3 +46,16 @@ indices/u_unfilled_gen.c: $(srcdir)/indices/u_unfilled_gen.py
util/u_format_table.c: $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format_pack.py $(srcdir)/util/u_format_parse.py $(srcdir)/util/u_format.csv
$(AM_V_at)$(MKDIR_P) util
$(AM_V_GEN) $(PYTHON2) $(srcdir)/util/u_format_table.py $(srcdir)/util/u_format.csv > $@
+
+EXTRA_DIST = \
+ Android.mk SConscript \
+ indices/u_indices.c \
+ indices/u_unfilled_indices.c \
+ indices/u_indices_gen.py \
+ indices/u_unfilled_gen.py \
+ target-helpers \
+ util/u_format.csv \
+ util/u_format_pack.py \
+ util/u_format_parse.py \
+ util/u_format_table.py \
+ vl/vl_winsys_dri.c